Adsense Ads aren't showing up even when the ad code is implemented correctly

my website is

I just got approved on Adsense

So I added the code into its proper location

but nothing is showing up

Just an Empty container

I don’t know why

I’m on the Pro version from Cloudflare

I tried everything Origin and Cloudflare nothing is working and still no ads are showing up

so can someone please help me

I’m using the Hosting of and this website is based on WordPress

So please anyone who faced this issue or knows and solution please help me ASAP

I’ve been trying everything for more than 10 hours straight right now

Waiting for your reply

have a very nice day

Stay safe


Here are my Active Plugins

By the way, I’ve tried to Pause Cloudflare and I’ve tried to Deactivate All Plugins

And still no ads are showing up

Please Help me

Did you wait five minutes for it to take effect? The general rule is you leave Cloudflare paused while you fix the issue at your server.

Just visited the site and ads are showing up.

Ads don’t show instantly after the code is applied - the pages are scanned by the AdSense bot (Mediapartners-Google) and then after some time they will appear.

Also, make sure you are not using an AdBlocker and blocking your site.


If I may add here, from my experience with WordPress + W3 Total Cache (all the caches) + Cloudflare (Cache Everything) + Google AdSense + Google AMP (cached + AdSense there too) …

Time and patience.
Google needs to scan the content on your Website.
Furthermore, scan for existing ads.txt file existance, etc.
After each post is being published, at least an hour after I do not see any Google AdSense ads appear due to either caching or Google AdSense needs to figure out what kind of the ad to create and show to the visitor (regarding cached HTML page + visitor paramerers like cookies, logged-in session, etc.).

  • I see ads after I hit refresh one-two times (after my first visit) in that hour of being published to get them shown, while later they appeary normally to the each visitor/user …
1 Like

Thanks everyone

It’s working now


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.