Admin bar persistently showing because of edit process

plugins

#1

(this really should be a separate topic but I’m not cool enough for that yet)

I use Cloudflare on my Wordpress site. Because of the theme I use, I have to do most editing from the front-end and not the admin area. This means I view the front-end pages while logged in as the admin.

If I make an edit, clear the cache, and reload the page the admin bar at the top of the page is cached. Anyone who visits the site after that will see it. I’m a little concerned that it might give them the impression I’m broadcasting private information all over the internet and things like that.

The only solution I can see is to manually visit the cached pages in an incognito window after clearing the cache. That seems like a lot of steps to go through just to make some edits to one page. Is there any other solution?


Speed Up WordPress and Improve Performance
#2

@richard1, You can pause CF or activate development mode (in both modes CF will not cache) or use Bypass by Cookie page rule (available on business plan).


#3

To echo what @cyBerManIA says, you really need to use Bypass Cache on Cookie:

You should not cache HTML produced by WordPress without this as it will cache private/personalised content.


#4

If nobody should ever use Cloudflare with a WordPress site without that one feature (Bypass Cache on Cookie), then why is that one feature way over in the Business plan for $200/month?!?!

I would gladly upgrade from Free to Pro for $20/month to pay for this feature, but honestly, if this is such a necessity to prevent displaying private/personalized information to the public, then why isn’t it included in the free plan?

Cloudflare, I’m a huge fan and advocate of yours, but this is embarrassing.


#5

I am here because my Virgin Plus account has been kidnapped by cloudflare. I don’t want a web site, I am in enough co.munities. Please return my Virgin account and then I NEVER want anything to do with you again.


#6

I’m a little confused as to how Cloudflare kidnapped your account. Cloudflare only steps in when you’re using Cloudflare DNS. Is Virgin Plus a Cloudflare partner? If you don’t mind posting your domain name, it would help in clearing things up.


#7

Maybe they got a Cloudflare error message trying to visit a site? And thinks we’ve done something to their account? Ah yes, the Virgin Pulse site appears to be using our under attack mode.


#8

Try this…
Install the Cloudflare plugin.
After editing a page, in wp-admin go to “Settings / Cloudflare / Purge Cache” purge everything.
That seems to do the trick…(on the one site I’ve tested :slight_smile: )