Address not found while sending email

I tried to send email on my custom domain. It shows error saying address not found. I have completed all the process for email routing. my custom
email: [email protected]
domain: hemantaphuyal.com.np

I currently see a consistent pattern for your MX records to be:

$ dig +noall +answer MX hemantaphuyal.com.np @rayden.ns.cloudflare.com
hemantaphuyal.com.np.   300     IN      MX      10 mx.zoho.com.
hemantaphuyal.com.np.   300     IN      MX      20 mx2.zoho.com.
hemantaphuyal.com.np.   300     IN      MX      50 mx3.zoho.com.

The settings you have made in Cloudflare Email Routing won’t work at all, when you are pointing your MX records somewhere else.

How exactly does the domain appear, on the front page (list of Websites) of the Dashboard?

→ https://dash.cloudflare.com/


here is the screenshot

If you scroll down under your DNS records, what name servers do you see there?

There is currently a split view from the domain registry for .COM.JP of what your domain’s name servers actually are:

$ for NS in `dig +short NS com.np`; do echo " -- $NS:"; dig +noall +auth NS hemantaphuyal.com.np. @$NS; done
 -- np.cctld.authdns.ripe.net.:
hemantaphuyal.com.np.   86400   IN      NS      thea.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      rayden.ns.cloudflare.com.
 -- ns4.apnic.net.:
hemantaphuyal.com.np.   86400   IN      NS      rayden.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      thea.ns.cloudflare.com.
 -- pch.nnic.np.:
hemantaphuyal.com.np.   86400   IN      NS      rayden.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      thea.ns.cloudflare.com.
 -- np-ns.npix.net.np.:
hemantaphuyal.com.np.   86400   IN      NS      thea.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      rayden.ns.cloudflare.com.
 -- shikhar.mos.com.np.:
hemantaphuyal.com.np.   86400   IN      NS      eve.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      morgan.ns.cloudflare.com.

Thanks to the split view from the domain registry, you currently have no control over which Cloudflare account is actually the “authoritative” one, for the domain in question.

… Have you recently changed name servers for this domain, for example less than ~ 48 - 96 hours ago?

Yes I have changed my nameserver around 20-22 hours ago.

Sounds like that would roughly be around 2023-03-13 @ 14:15 - 16:15 UTC (… or 15:15 - 17:15 CET) for the change of name servers.

My suggestion would be to wait and have some patience regarding that, as changing name servers aren’t really going to be instantaneous (and in most situations, far from).

You can however verify through the domain registrar, that they still see EVE and MORGAN as the actual name servers there.

If the issue persists for more than 96 hours after the actual change of name servers, I would escalate the issue through your domain registrar.

1 Like

As of 2023-03-15 11:46 UTC (12:46 CET), it seems like the name servers (at least, from the parent registry) is fine now, - with a propagation time on the parent on (up to) around 44-46 hours:

$ for NS in `dig +short NS com.np`; do echo " -- $NS:"; dig +noall +auth NS hemantaphuyal.com.np. @$NS; done
 -- ns4.apnic.net.:
hemantaphuyal.com.np.   86400   IN      NS      morgan.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      eve.ns.cloudflare.com.
 -- pch.nnic.np.:
hemantaphuyal.com.np.   86400   IN      NS      morgan.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      eve.ns.cloudflare.com.
 -- np-ns.npix.net.np.:
hemantaphuyal.com.np.   86400   IN      NS      eve.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      morgan.ns.cloudflare.com.
 -- shikhar.mos.com.np.:
hemantaphuyal.com.np.   86400   IN      NS      eve.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      morgan.ns.cloudflare.com.
 -- np.cctld.authdns.ripe.net.:
hemantaphuyal.com.np.   86400   IN      NS      eve.ns.cloudflare.com.
hemantaphuyal.com.np.   86400   IN      NS      morgan.ns.cloudflare.com.

So things you’ve been playing with should at least be starting to work now, if they aren’t alrady. :slight_smile:

now it is working.
thank you!

1 Like