Additionnal redirect when enabling cloudflare, how to fix?

When I enable Cloudflare, I get a double redirect link from https//:www. to https://, which sometimes can cause a redirect loop and lower the performance of my website.

When I turn it off, I get 100 scores. Which parameter should I modify to remove this extra redirect ? Thank you

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict ā€¦ )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

1 Like

Before moving to Cloudflare, was your Website working over HTTPS connection?
Yes

If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?
Iā€™m pretty sure. It was done through Dreamhost.

May I ask what SSL option have you got selected under the [SSL/TLS tab] at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict ā€¦ )?
Full Strict.