Adding txt record


#1

I’m using Postmark so I can use the bbPress plugin Post Via Mail - so users can reply to forum posts directly from email. I’ve added appropriate txt records (SPF and DKIM) to cloudfare DNS but they don’t seem to be published and aren’t pointing traffic in the right direction. Can anyone help me?

Thanks!


#2

I don’t think you need this in the value for your dkim record: "Key Value: "

Other than that both appear to show up for me when I do a DNS query for them.


#3

I’m getting this message in my email when I try to reply to forums from my email:

Address not found
Your message wasn’t delivered to [email protected] because the address couldn’t be found. Check for typos or unnecessary spaces and try again.

Did I mess up the setup some how?

Thanks,
Sam

Samantha Langlois
MS Conservation Biology

139 Jesse Robbins Rd

Belfast, ME 04915
207.232.2447

www.organiclifeguru.comhttp://www.organiclifeguru.com


#4

So there are a few mail related records. The SPF record you have is one which indicates what servers are authorized to send mail on your behalf. The DKIM record is a record used to sign outbound emails that a receiving MTA can use to determine if the message was sent by a valid server/service.

But there’s another record call MX which says what mail server is configured to accept mail on behaof of your domain and you don’t have one of those records in your DNS.

For example for my personal domain I receive mail @ Office 365 so my Mx record looks like this when I query DNS:

dig tenlions.com mx +short
0 tenlions-com.mail.protection.outlook.com.

It looks like this plugin also requires Postmark inbound for reply parsing, which i would assume includes steps to set up an Mx record for the reply domain among other things. https://github.com/jjaffeux/postmark-inbound-php/tree/54e6b5813efc050471c47a0c7304b87f6f5a7177

Sorry not terribly familiar with the service or plugin.


#5

Thanks. Postmark tells me I don’t need an MX record in order for forum members to reply to forum posts from email. Any other thoughts? This is kind of driving me crazy:)

Sam

Samantha Langlois
MS Conservation Biology

139 Jesse Robbins Rd

Belfast, ME 04915
207.232.2447

www.organiclifeguru.comhttp://www.organiclifeguru.com


#6

Well OK, technically there two instances in which one doesn’t need an Mx record.

  1. If you don’t want to receive mail for that domain.

I think we can discount that one because we’re having this conversation. :slight_smile:

  1. In the loosest possible sense an Mx record is not technically required by the strict reading of the RFCs that govern SMTP (email). Technically if there isn’t an Mx a host should try to send to the A record if one exists (different DNS record which maps the host name to an IP). However, in practice this is a bad idea for any number of reasons… including in this case that Cloudflare doesn’t proxy SMTP traffic. So a specific Mx record is required to designate a host which can receive mail. I think another issue for you specifically is that I don’t believe the service hosting your site supports SMTP inbound either (not disclosing that here, but pretty sure if you ask them they’ll tell you that’s true).

So the reply address needs to be some type of a valid Mx record. I’m not sure exactly how the reply by email thing is supposed to work in this plugin (whether it can read from a normal POP3 style mailbox or whether it needs to use an inbound mail service like Postmark) but the mail has to route somewhere for that plugin to route it and Mx records are ow servers know where to send the message.

I realize that is really long winded and not a huge ton of help. Hopefully either someone else in the forum is more familiar with the plugin or if not, you might ask the plug-in creator if they have any insight.


#7

Thank you.

The folks at Postmark say they can’t find the DNS records as published.

“I would push back on Cloudflare a little more. When I do a look up for your SPF record in DNS it’s simply not showing up. Can you ask them to check and show you the result of a look up? Or have them double check your settings and make sure it’s correct to their standards?”

Any thoughts?

Thanks,

Sam

Samantha Langlois
MS Conservation Biology

139 Jesse Robbins Rd

Belfast, ME 04915
207.232.2447

www.organiclifeguru.comhttp://www.organiclifeguru.com


#8

The DKIM shows up

dig 20170929153334pm._domainkey.belfastareahomeschoolresourcecenter.com txt +short
“k=rsa; p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQCFx+Aw/9WL35Ldy7QWu7oWmBRqtyJAgGr4LA2ke2UYU19GEUwc2sqYAvsCfVBytbmDa5usnp9gcI/ulA+Yl2OQ8DvzYPOl93bEH8ZRcKQX7eJVRfBw9CVpsv6yauy4maxugueMWD8S3E2fBcEI2EcUvTfG8dM1UBdn04LyGghcBwIDAQAB”

You have a typo in the name of your TXT record (you misspelled resource). Not sure when that was introduced, I believe it worked when I looked it up previously, but if you correct the typo it will work as well.