Adding domain - A record and CNAME record

Hi, I’m trying to add my domain, but when I add the A record and CNAME record, it says they already exist. But then when I try to add my name it says there is no A record or CNAME record.

How do I fix this?

What do you mean by your name? Like subdomain records?

I’m dumb. I didn’t mean to say name I meant to say ‘the record’.

So when I try to add the A record or CNAME record it says they already exist. And then I try to add my domain on ‘go high level’ and it says it can’t find an A or CNAME record.

Here are two pictures:

And here is another picture of what it looks like when I try to add the records

When you enter the record for @ it will appear as the apex domain on the page, e.g. Scroll down the page in your DNS records and look for your apex domain. If it is on the list, make sure that it is not set to :orange: or the IPs returned will be Cloudflare IPs. Set it to :grey: and check the add domain screen of your SaaS app again.

I just did that and it didn’t work. It’s saying the same thing. Thanks for trying

When I lookup your domain, I get Cloudflare proxy IPs. That means it has to still be :orange:.

Are your assigned nameservers maria and sevki?

Yes, I changed my name servers (on bluehost) to maria and sevki. Here is a picture of my records. What should I change? I’m going to add another picture after this one so you can see all of my CNAME records.

Here is the second pic. Also, thank you for replying, no one else seems to know how to fix this.

I see two obvious problems. You have two A records for the apex name. One is set to :grey: and points to your SaaS provider’s IP. The other is :orange: and points to your cPanel hosting. You cannot have both. If you want the apex name to direct visitors to the SaaS page, you need to delete the proxied record that points to your cPanel host.

The second problem ain’t impact seeing up your custom name with your hosted service, but it could lead to undesirable results later. The webmail CNAME points to your apex. If you plan on keeping the apex pointed at your cPanel hosting this is fine. If you intend to send the apex to the SaaS platform, it isn’t going to work.

Based on what I see in your MX records, it looks like you are using Google Workspace for your email. If you want the webmail hostname to send your users to their Google Workspace Gmail, it can be done, but I wasn’t able to find a ready made guide right now.

It would be beneficial to take stock of all the default cPanel records and delete those that you don’t need. I expect that will be most, if not all, of them. It is a good idea to export your DNS data from your Cloudflare dashboard before you start that project, especially if you are unsure as to what records are safe to delete.

You have two A records for - see the one pointing to the 162.241 IP address. Delete all of the A records named except for the one you want - and leave it grey-clouded until your provider in the original screenshot can validate it.

Thank you so much. It worked! The CNAME record is still giving me issues.

Thank you!! It worked. But now the same problem is occurring with my CNAME record.

It’s saying it can’t find a record for ‘flash.funnels.msgsndr…’ but when I try to add it it says that the record already exists.

That is because you already have that CNAME pointed at

If I delete the CNAME that targeted to clickfunnels, what will happen to the clickfunnel?

Traffic from www certainly won’t go to ClickFunnels any longer. You can’t point one name to more than one destination. You have to decide where it should go and update the name accordingly.

Thank you so much!! I really appreciate it. No one else was able to help me.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.