Adding CNAME for Google Sites

The problem is, when i try to add CNAME with target " ghs.googlehosted.com." and save this, i get " ghs.googlehosted.com" (without dot). How to add this with .? it is really important. Thanks for help

1 Like

You mean when you add cname in cloudflare dash the dot in subdomain is automatically removed, but it can’t happen maybe your keyboard issue.

It looks i write ghs.googlehosted.com. and when i save this, Dot is getting removed auto

Oh you are talking about last dot that is full stop it won’t be proper cname if you will add with dot cloudflare knows some beginner does this mistakes that’s why it removed the dot automatically In reality there is no need of that dot it’s just a full stop.

I think there is needed this last dot, because without this dot it doesnt work

There is written, this dot is needed

No it’s not needed it’s full stop please try to understand me, I am a web developer just go ahead and use without dot and If you are unable to see your google site live on domain firstly remove that cloudflare proxy by clicking on cloud so that google can check for the dns changes and then activate cloudflare proxy.

Give me the link it’s impossible.

Do I have to wait next 24h now?

Nope have you added the CNAME, If yes then changes should be live, try changing your dns or clearing your dns cache so that you can see the changes and If I can get a link to it I can see if your dns records are configured correctly or not.

There is not error 404 anymore!
But there is another error hah
ERR_QUIC_PROTOCOL_ERROR

Go to SSL settings and set SSL to full as google is also applying ssl it’s conflicting.

Then you will know it’s not a full stop either.

Bad advice.

Why so google sites are using server side ssl!

However error seems to be related with http/3

Because it should not be Full but Full Strict.

Still It doesn’t work;

@michalsliwa04, you have an insecure setup now.

Full Strict doesn’t work too

@sandro OH!! Read it properly when server is using cloudflare origin certificate then Full Strict is used.

No, it does not and I’d strongly suggest you familiarise yourself with support.cloudflare.com.

@michalsliwa04, did your site work fine on HTTPS before Cloudflare? If not, then that’s your issue.

After domain bought I changed into CloudFire
I did not test without this