Adding Cloudflare NS to registrar won't work

Guys we are having problems adding Cloudflare’s name servers to Brazilian https://registro .br.

Currently have some free domains on our account on cloudflare. As of yesterday, as we add new domains in cloudflare free plan, everything seems to goes smooth as always but when we try to update the registrar with cloudflare’s name servers it gives us the error query refused.

The domain I’m trying to add to cloudflare free plan is pizzariadonnale .com.br
Cloudflare NS servers are tara .ns.cloudflare.com and walt .ns.cloudflare.com

Below is the output of DIG

; <<>> DiG 9 <<>> @tara.ns.cloudflare .com pizzariadonnale .com.br A
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 21370
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;pizzariadonnale .com.br. IN A

;; Query time: 13 msec
;; SERVER: 2400:cb00:2049:1::adf5:3ae1#53(2400:cb00:2049:1::adf5:3ae1)
;; WHEN: Thu Oct 3 22:15:10 2019
;; MSG SIZE rcvd: 40

and below is nslookup output

nslookup pizzariadonnale.com.br. tara.ns.cloudflare.com
Server: tara .ns.cloudflare.com
Address: 173.245.58.225#53

** server can’t find pizzariadonnale .com.br: REFUSED

Below is cloudflare screen after adding the domain

I also tried to add the same domain using a differente cloudflare account that
uses uma .ns.cloudflare.com and lee .ns.cloudflare.com having the same results.

Please help
Thanks in advance…

Hi @suporte22,

I did a dig +short pizzariadonnale.com.br NS and saw that the current nameservers are different from that displayed in your screenshot:

e.sec.dns.br.
f.sec.dns.br.

If I am not mistaken, Registro.br requires an interval of 2 hours between nameservers changes.

What is the current situation of this case?

By the way, we can talk in portuguese if you prefer. :blush:

1 Like

Hello and thanks for helping me looking into it.
I will keep in english if that’s ok let’s help guys to build a good knowledge base. This may happen with other registrars.

I couldn’t change to cloudflare name servers on registro.br. Below is the error message.

Any help is appreciated…

1 Like

If you are able to change nameservers, then my assumption about the problem being related to the time frame imposed by Registro.br is not valid.

Sorry for not being able to solve your problem.

Let’s hope some other community member with sufficient technical knowledge can help.

Thanks for looking at this.

It shouldn’t be an issue with the registrar. We called them and also tried to configure the domain through AWS Route 53. It works.

I was hoping someone could check the output of dig and nslookup I have added. We tried both dig and nslookup with other domains we have and it shows ok responses. Those I paste aren’t ok.

Best regards

That doesnt appear to me as a registry or registrar issue either. Cloudflare simply does not seem to know about your domain. The Cloudflare screenshot you posted is a current one, is it not? If that is the case, you could first try to remove the domain from Cloudflare and add it again. Should that still not work, you would have to open a support ticket.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.