Adding an SPF(and DKIM) record - no TXT option?

I’m trying to add an SPF record using MXToolbox’s SPF generator, but in the Type drop-down field for our DNS settings, I’m only seeing A, AAAA, and CNAME. Shouldn’t there be a TXT option there?..actually, not even seeing an MX option, though I already have that in place from when this was initially set up.

I feel like I’m missing something obvious, but any help would be appreciated. Thanks in advance…

Your zone is set up in a CNME option, so your authoritative DNS is somewhere else. For records such as TXT those need to be created in your authoritative DNS for the zone.


Ah, you’re right. Thanks for the prompt reply!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.