Adding a new .ch domain registered 45 hours ago is not working


I can’t add to Cloudflare a new .ch domain registered 45 hours ago. I get: domain-name***.ch is not a registered domain.
The domain looks ok on for more than 24 hours, I put the DNS nameservers from my Cloudflare account at registration.
I am using Cloudflare since May 2018 and newly registered .ch domain were visible on Cloudflare in less than 8 hours.
It should be a technical problem somewhere between Cloudflare, and the domain registrar.

what is the domain name ?

there is no technical problem in Cloudflare, I have been monitoring Cloudflare every 3 minutes

can u share the DNS records of your domain?
you might have not added GoDaddy A records correctly , let me have a look

You can check here Lookup - Internet Domains
the domain is registered since 7 December.
As I said, I use Cloudflare with .ch domains since 2018, it took just a few hours for new domains to be available for adding on Cloudflare.
Now it’s more than 48 hours and “is not a registered domain”.
This is not normal behaviour.

Have you disabled Cloudflare and checked that your site is actually not working with cloudflare?

How I can disbale Cloudflare if I can’t add the domain to cloudflare in the first place ? :slight_smile:
That’s the problem.
Cloudflare says “is not a registered domain”, but the domain is registered since 49 hours.

Or you mean to use an alternate DNS service to check if the domain works ?

This is quite confusing , your domain is having Cloudflare nameservers

At GoDaddy you can put whatever nameservers on your domain, even if the configuration is not done on DNS provider side.

In the first place, where did u get these nameservers from?

From my Cloudflare account, all my other websites have the same nameservers.

I will suggest you to once remove the nameservers and wait for 2-3 hours and then retry

Yes, I just set the GoDaddy default nameservers, on they updated in 1minute
and I will retry later with Cloudflare.
Something is wrong between Cloudflare and

I just added the site on Cloudflare, it worked.

Thank you for the suggestion.