Adding a CNAME record in Cloudflare pointing to a Heroku hosted application


#1

I have a NodeJS application hosted on Heroku and I’m using Cloudflare to handle my DNS settings.

Unfortunately, the root domain for my application won’t resolve since I don’t have CNAME record pointing to it and correspondingly, I also receive the following error on my Cloudflare dashboard:

"An A, AAAA or CNAME record was not found pointing to the root domain. The XXXX.com domain will not resolve".

I found the relevant documentation for Heroku-hosted apps (shown below) which explains that all I need to do is to add a CNAME record for my root and point it to the server name. (It also states why I can’t point it to a static IP address)

My problem is - how do I add a CNAME record pointing to the server name when the field I’m supposed to add the server name to only accepts an IP address?

See below screenshots.

Additionally, I’m further confused by the following piece of documentation:


#2

Put a @ in the “Name” field. The @ means “root domain.” You might even be able to put your “example.com” in the Name field.


#3

Thanks for the suggestion but I just gave that a shot and I’m still not able to put anything other than a static IP address in the field where I should enter the server name


#4

I’m stumped. I was able to do it.

How about…some other CNAME? Start with a CNAME for ‘blog’ and point it to ‘example.blogspot.com’. Yes, use those exact entries…just to see if CNAME is broken for you or not.

If that gets accepted, then change the ‘example.blogspot.com’ to cf-solutions.herokuapp.com

If THAT gets accepted, then change the ‘blog’ to @ or your actual domain name.

If there’s a failure along the way, open a Support Ticket. I just tried this procedure and it worked.


#5

Doesn’t seem to work for me :frowning: May I ask if the input field for you looks the same as mine (see below)?


#6

It may be a browser issue. As soon as I switch to CNAME, the input field immediately changes to “Domain name”. I see yours is stuck on IPv4 Address, like it’s waiting for an A record. Try clearing your browser’s cache and/or switch to a different browser.


#7

OMG YOU’RE RIGHT. I was on firefox and now I’m on Chrome and it switched over!!!

This is how it looks now.


#8

All working now :slight_smile: Thanks so much for your help!!


#9

This topic was automatically closed after 14 days. New replies are no longer allowed.