Added Site To Cloudflare, But SSL is still Not active

Yesterday I added my site to cloudflare, and even got a message “Your SSL/TLS encryption mode is Flexible” and on overview got another message" Great news! Cloudflare is now protecting your site" however, my site is still “NOT SECURE” where is the issue? the DNS Name Servers are with Homestead and the site is hosted with Go Daddy

Maybe your browser knows you’re using Flexible, which isn’t secure. But browsers aren’t that smart.

What’s the domain? It’s probably Mixed Content.

2 Likes

I checked on https://www.crawlcenter.com/ and the exact message I got was the following [No insecure/http internal links found i.e. No Mixed content found!]

I believe I did everything right, I changed the DNS nameservers on Homestead to the 2 provided by Cloudflare, now I’m just waiting but nothing, so did I mess up somewhere? or is it taking more time? Where is the glitch is my question? Cause I’ve done other sites, that after 10 minutes their sites are secured.

@seanpierce.ppcxpert , you need to add your domain name, so @sdayman will be able to help you.
You haven’t provided enough information.
Check WhyNoPadlock for reliable mixed content results, or do it the classic way, Inspect Elements on Chrome, and Source check.

Hey Stefano, I actually did a test on whynopadlock… these are the results…
https://www.whynopadlock.com/results/2a82c5bf-96ea-48c4-ba8b-e5a63390f1c3
according to that everything is fine, so why is the site still Not Secure? or do I have to give it more time? it’s been almost 24 hours

my site is http://ranchovistapools.com/, and I did a test on whynopadlock… the results are in the link.
https://www.whynopadlock.com/results/2a82c5bf-96ea-48c4-ba8b-e5a63390f1c3
according to that everything is fine, so why is the site still Not Secure? or do I have to give it more time? it’s been almost 24 hours

I don;t see any problem with your CERT.
Can be,
The version of the browser you are using.
Cache of your browser.

Try to visit your website from another machine, network, restart your rooter (Modem), clear browser cache.

Check also the difference between CloudFlare’s SSL

1 Like

Well, I already cleaned my cookies and cache, but still site Not Secure, so I don’t know what could it be, question though, what’s (Check also the difference between CloudFlare’s SSL) how do i do that?

I will try to make simle:
If you check here https://www.sslshopper.com/ssl-checker.html#hostname=https://ranchovistapools.com/
The certificate looks all ok.

This sound be an issue on your end.
Have you tried to visit your website from a different machine?

(Check also the difference between CloudFlare’s SSL)

I mean, read the article I have send, to learn more about the type of the Certificates and how they work.

I read the article, and it’s a bit hard to understand fully, Im no web developer just basic. so trying to figure out how to fix this up…

So, @seanpierce.ppcxpert
Please try do as we recommended in our previous conversation.
You should probably, need to restart your rooter, if you don’t have a static IP in your house/office, that will do the trick, your rooter will get a new IP and you will be able to see your website with no SSL issues.

1 Like

Hey there, i see the padlock on the domain, however I cannot see my site. I called Go Daddy and they are saying the A records are not pointing to Go Daddy, so question why is the site not showing? and how do I change the A records on Cloudflare to point to Go Daddys A record?

Hey there, so now today, i see the padlock on my domain, however I cannot see my site. I called Go Daddy and they are saying the A records are not pointing to Go Daddy, so question why is the site not showing? and how do I change the A records on Cloudflare to point to Go Daddys A record?

1 Like
1 Like

That!

@seanpierce.ppcxpert, before you do anything else, you need to get your webserver properly configured for HTTPS.
Right now, it neither has a valid certificate nor does it even return your site on that invalid certificate.

As long as your site is not secure, there is little point in proceeding. You need to contact your host for that and get a proper certificate up and running on your server. I’d also suggest to use the search, as that topic has been covered more than just once.

I am facing the same issue - Active SSL Certificate but website not secure. I have the " Always Use HTTPS" and “Automatic HTTPS Rewrites” ON & believe added the cloudfare nameservers properly on my website DNS settings. Would that be because I am using flexible ?

My website is https://rasayanam.in/ .

Please read this thread’s Solution.

2 Likes

This topic was automatically closed after 30 days. New replies are no longer allowed.