Added page rules but still showing cf-cache-status : Dynamic

Hello team,

Please refer site url :- https://bizim10.com/

I am setting up CDN on this site but cf-cache-status is showing Dynamic instead of HIT. Can you please check and guide me on this? I have also checked with different page rules but still, it’s not working.

Please post a screenshot of all your Page Rules.

Thanks for your response.

Please refer to screenshot:- Screenshot by Lightshot , Screenshot by Lightshot

Hello is there anyone help me on this?

The “Cache Level” should be “Cache Everything”.

If you still want to maintain the behavior of “Ignore Query String” while caching everything, you may refer to this on how to use Transform Rules to achieve the same result.

1 Like

Thanks for your response.

I have set the cache level. Please refer screenshot :- Screenshot by Lightshot

But still, cf-status is showing dynamic.

You may retain all the settings as shown in your first screenshot, you just need to change the “Cache Level” option to “Cache Everything”, while leaving other settings the same.

Also, if you want to match all URLs starting with https://bizim10.com/, then your matching URL should be https://bizim10.com/*.

Please refer screenshot:- Screenshot by Lightshot

I have made changes as per your suggestion.

But still, cf-cache-status is showing Dynamic.

Try add another option called Edge Cache TTL with any duration you prefer (e.g. 1 hour).

Please refer to screenshot:- Screenshot by Lightshot
I have added But still showing Dynamic cf-cache-status

Unfortunately, Lightshot doesn’t work for me, which is why I hadn’t responded. Are you able to add images directly to your posts?

Sure @sdayman ,

Please refer to below Image of page rule.

Can you please check and guide me on this?

I’m sorry, I just noticed you’re using Kinsta. I don’t think you have control over your settings, as Kinsta has their own Cloudflare integration, and their settings take priority.

I had disabled kinsta cache from the server.

I have also talked with kinsta team and the guy told me I need to check with cloudflare team.

Are you able to clarify which settings Do you need so I can check with the same?

That doesn’t change the fact that Kinsta controls your domain’s settings, including Page Rules.

I suggest you talk to a different guy. I believe that Kinsta’s Cloudflare integration is new, so he might not be familiar with the setup.

I’m pretty sure you’ve got this right, but can you confirm that the name servers at the bottom of your DNS page at dash.cloudflare.com are Adam and Cheryl?

1 Like

Okay, I will talk again with kinsta team.

Please refer to the screenshot of the name server.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.