Add a domain to Cloudflare - Invalid domain

Hi everyone,

I am new to Cloudflare so please forgive me in being very unfamiliar to it all. I have created an account and I am in the process of attempting to add a domain to Cloudflare, which excludes https:// and also the www. in the web address, yet it still comes back as invalid domain.

I have also contacted my ISP provider of this DNS following on this troubleshooting article I came across (source: I cannot add my domain to Cloudflare... – Cloudflare Help Center) and they have confirmed that the DNSSEC is disabled. I am none the wiser and would be grateful for some help & assistance here. The purpose of utilising Cloudflare is to provide an extra security layer to my website portfolio, so some guidance would be appreciated.

By which you don’t mean HTTPS, right? Your sites currently loads fine on HTTPS, does it not? That’s a common misconception.

You’ll probably have that issue Community Tip - Fixing Code: 1049 is not a registered domain and that article also mentions the fix.

But, what’s the domain?

Hi Sandro,

Thanks for your prompt reply. It was suggested to me by a friend who said that it would protect my website. Yes my site does load fine on https:// the domain ends in .uk. Are you suggesting that Cloudflare only provides an encrypted layer?

I’ve taken a look at the article that you have kindly provided, and I think it does appear to return a nameserver according to

The domain name is definitely registered though

That’s too generic to comment on. Cloudflare does have some security features but a lot depends on what you actually need and things won’t become “more secure” out of the box.

That’s good then. People often think Cloudflare alone provides HTTPS and they don’t need a proper setup on their server and that’s incorrect.

You need to post the domain if you want more advice. Plus post the exact error message.

Sorry Sandro. Well perhaps this is where I am unsure of it. As far as I am aware, I want to try and give my website portfolio the best protection it needs from hackers or any form of security flaws. I recognise that the first step in protection was to purchase an encryption SSL certificate. Beyond that, I’m none the wiser.

I am aware that Cloudflare doesn’t provide https alone and also that I need to have a proper setup on my server which is why I am reaching out for support & assistance.

Domain should add just fine


I’d suggest to try it one more time.

Should it still not work, then I’d say try another browser and eventually contact support.

But generally speaking, there is nothing that prevents the domain from being added.

Yet this is what I tried to add, still coming back as invalid domain… unless… given you’ve tried and it worked… yep I wasn’t reading the instruction properly and should have omitted the forward slash at the end which solved it. Thanks for your help & assistance Sandro!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.