Active SSL Certificate - SSL/HTTPS showing self signed on non-www (www workiing)

#1

Hey team,

The Universal SSL Status is showing a Active Certificatestrong text**** status - however browsing to https://mywebsite.com is only showing a self signed certificate. An error message from FireFox:

MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

SSL/HTTPS is working without issue on https://www.mywebsite.com. My question is - if it’s working on www - should it also be working on non-www ?

Cliffnotes of setup:

  • Website hosted with InfinityFree
  • DNS managed with Cloudflare
  • SSL enabled - shows as active
  • HTTPS only showing self signed cert on non-www. www working
  • @ and www points to InfinityFree (DNS and HTTP proxy (CDN)

Am I missing out on other DNS records for this?

Many thanks

Oak

0 Likes

#2

Hi. Are you able to share your domain name so we can take a look?

0 Likes

#3

Cheers:

oakface.club

1 Like

#4

I am redirected from oakface.club to www.oakface.club where the certificate works fine. The Cloudflare cert covers both and should work. Given that you see the error and no redirect, I suspect a propagation issue. Do you have another device / connection you can try it on or try clearing your cache? Alternatively, I think it should work after a while for you as it does now for me.

0 Likes

#5

Thanks for checking. I forgot to mention I’ve got a page rule to set that forward so that’s great it’s working. Where are you located geographically if you don’t mind me asking?

I’ve tried on a few devices (after CTRL + F5 clearing cache) on different networks to the same result - I was chocking it up to hopefully being a propagation thing. I’m located in Aus - maybe it’s slow getting to us haha

1 Like

#6

No problem :slightly_smiling_face:. Yes, the page rule seems to be working fine. I am located in the UK.

I would give it a while and hopefully it will work for you too!

0 Likes

#7

Thanks legend. Are you able to specifically test https//oakface.club ?

This is what I’m getting (not even redirecting :frowning:

1 Like

#8

It’s working. If you moved recently, clear your DNS cache. Using incognito mode is also worth a try.

2 Likes

#9

Sweet, thanks for your help lads

1 Like