Activating XMLRPC

Hey all,

I am using a 3rd party service called Narrative to design image layouts for my blog. Narrative uses XMLRPC to publish directly to my blog. But I keep getting an XMLRPC error. I’ve contacted their support and they’ve said it seems like something in Cloudflare may be blocking it. How can I ensure that XMLRPC is permitted and their IP is whitelisted?

Their IP address is and their FQDN is


Are you seeing anything in the Cloudflare Firewall Events log? (it’s at the bottom of the Firewall settings page).

I ask because my WordPress sites behind Cloudflare had XMLRPC enabled and would constantly get probed, so I turned it off.

I don’t see anything in the firewall, no.

You can certainly try to whitelist that IP address in the Cloudflare Firewall settings page in the Access Rules section.

Can you watch your server log as you attempt an update? That will at least tell you if it’s getting through Cloudflare.

For further testing, you can go to your Cloudflare Overview page and use Quick Actions to put it in Development Mode to bypass caching and other features.

For fullest testing use the Advanced settings in the Overview page to “Pause” Cloudlare. This will completely bypass Cloudflare. Just remember to un-Pause it when you’re done.

This topic was automatically closed after 14 days. New replies are no longer allowed.