ACTION REQUIRED: URL Normalization has NOT been enabled on your Cloudflare zone(s)

I was hoping you’d know! :laughing: I’m new to this community game!

Might be easier to drop me an email - smarsh AT cloudflare com

1 Like

haha will do

Sent (check Spam as I get sent there a lot :rofl::sob:

Maybe you can include a dynamically normalized expression preview in firewall creation rules as a hint ??

image

3 Likes

By design only some groups can DM others, so as an FYI, we in MVPs and Cloudflare Team groups can DM others (for example by opening the profile of another user and hitting “message”), but normal user trust levels can’t do so unless first contacted by someone.

Thanks a Lot Smarsh for the detailed examples!

Most of the FW Rules I can now adapt :smiley: But I have some rules where I’m still not sure…

Would you please tell me if the following examples need to be changed?

(http.request.uri contains "/wpad.")

(http.request.uri contains "vuln.")

(http.request.uri contains ".env")

As i have the Configure Normalization also under Page Rules, do I have to do here for exclude wp-admin / wp-login and cache All Rule something?

*.mydomain.com/*wp-admin/*
*.mydomain.com/*wp-login.php*
*.mydomain.com/*

email delivered :smile:

Replied via email, but copying here also for others who have encountered the same strange issue:

Just looked into this as we’ve had 4 reports of this now, it appears there is a UI bug where its misreading the backend logic and falsely reporting normalization on incoming requests as ‘enabled’ for zones who were opted-out by default. We’re creating an urgent fix for this now.

It wont be affecting your traffic flow, as normalization is not enabled. However, if you want to enable it then simply click the button twice (i.e. enable > disable > enable) and this will force it to be turned on correctly.

Thanks everyone for helping us figure this out so quickly, keep the reports and feedback coming!

6 Likes

This is now fixed. Thanks for your patience, everyone!

3 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.