Account Dash Ticket - SSL Edge Universal expired. Place order certificate button is not active

End of February, I created ticket #2385980 “SSL Edge Universal expired. Place order certificate button is not active. I need a new one.” for the site

The Universal SSL certificate has the status “Expired (Error)”

The support staff told me that they could not proceed with the change because my username was not the account owner. They closed the ticket.

I directly created a new ticket #2388972 related to the ownership.
Finally, after one month, I got a reply from support yesterday confirming that I am the owner of the domain"

Also, that should point the nameservers to Cloudflare nameservers (more details below) and follow the Community blog fixes for the SSL certificate problem, which I did. (Disabled Universal certificate, waited long and reactivated it)

Though, I can still not order/renew the universal SSL certificate.
I answered to the support, and they closed the ticket, telling me to create check community fixes and create an inquiry if unsuccessful.

I read several threads with a similar problem, and it seems that support had to fix it in the end.

Info about the site history: back in 2015 using Cloudflare nameservers.
Then integrated it with Siteground in 2021 using Siteground nameservers + their Cloudflare integration.

Back in February this year, I implemented Ezoic ads.
Once I added the Ezoic Cloudflare integration, my site got the “SSL Edge Universal expired. ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I realized that the Edge certificate expired and created the first ticket, #2388972

Yesterday I pointed back to Cloudflare nameservers and tried the suggested fixes without success.
However, I need to get a Universal SSL certificate to be able to integrate Ezoic with Cloudflare.

I hope to find out how to get that fixed.

Thanks in advance,

It’s stuck in an endless redirect loop

With regards to that: I would recommend you attempt to create another SSL certificate

You can view instructions on how to do this from this fantastic video made by @albert

Alternatively, you can view this thread (which contains the same video above)!

Also, for fixing the ERR_SSL_VERSION_OR_CIPHER_MISMATCH error

@AppleSlayer, thanks a lot for your help.

[quote=“AppleSlayer, post:2, topic:374683”]

The site is currently functional, not having any endless redirect loops.

I watched the video. My site is on Full SSL setting.
Though the issue I have is not the SSL certificate on the hosting side which is functional, I forgot to mention that I ordered a new Let’sEncrypt certificate when I first got the issue, but it did not help to get a new Cloudflare Universal certificate.

The problem I have is that I am unable to order a new Cloudflare Universal certificate.
I disabled and enable the Universal SSL button several times. Waited from 5 minutes to several hours before enabling it again

But the “Next” button remains inactive, no way to order a new Cloudflare certificate.

I’m sorry to have to say this, but you have an insecure website!

Please change your SSL to FULL (STRICT)

Your “Full” SSL setting could be the entire cause of this issue!

Sorry, my bad, I wasn’t precise enough and should have included a screenshot…
The site was already on Full (Strict)…

Though, it shouldn’t make any difference in the Cloudflare Universal SSL renewal process issue… I believe.

What is the nameserver pair you see below your DNS records?

Hi Dom,

Can you try disabling Universal SSL at the bottom of the SSL/TLS tab, wait 5 minutes and re-enable it. See if that comes up under edge certificates as a new cert.

I tried it already a few times with different waiting times from 5mins to hours…
Nothing changes under the Edge certificate.

I’m not able to order or renew it…

Can you try switching the cert authority between digicert and letsencrypt with the API and see if that makes a difference?

1 Like

Dom, it’s getting a bit technical and don’t have the skills…

On my host, I do have a valid and up do date Let’s Encrypt certificate, but no Digicert is available on my Siteground hosting plan I believe.

This is not related to the certificate at your host, but to the edge certificate. I’ll see if someone from support can take a look if you’re unable to use the API to look at this.

This is not related to the certificate at your host, but to the edge certificate. I’ll see if someone from support can take a look if you’re unable to use the API to look at this.

Dom, that would be great, I opened a ticket about it over a month ago, and it was by mistake closed
saying that I wasn’t the site owner, it took a month to validate the ownership via a new support ticket and here we are…

Thanks a lot for your help!

1 Like

This should be resolved now, support did what I suggested you tried with the API manually and your certificate should be active.

1 Like

Thank you SO much Domjh!

All fine now. By the way, would you know of some existing tutorials for non-technical people on how to use the API? Are there videos available, I couldn’t find them?

I think we need to download cUrl on the computer, create API tokens in Cloudflare and then use the API documentation and run cUrl via command prompt in Windows, though if a step-by-step video for beginners exists that would help.
(I tried and created an API token, but the test script that was provided returned an error in the command prompt…)

Have a great day!

No problem, glad we were able to get it sorted for you!

I’m not sure there is any basic tutorial and the API does generally require a bit of experience. Yes, you would use curl and API tokens.

Windows can be a bit tricky and it’s much easier with a bash shell. Zendesk has a pretty good guide here but it won’t address Cloudflare specifics. If you want to get started with using the API, I’d recommend following the guide to getting a bash shell on Windows using WSL - you should then just be able to copy/paste from the API docs and change the parameters rather than spending time trying to get it to work in a normal windows command prompt.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.