Accidentally deleted Universal Edge certificate

I accidentally revoked/deleted the univeral, free Edge certificate that is auto-generated after adding a site and now no SSL will work. I usually use the origin server certificate, and I’ve properly adding that to my godaddy servers, but that didn’t change anything. I also removed and re-added the website to cloudflare and it still didn’t regenerate a new universal edge certificate.
It just says:
“No certificates” and won’t led me re-add the free universal one…

Any help would be greatly appreciated!

At the bottom of the SSL/TLS Edge Certificates page, does the button say to Enable…or Disable…Universal SSL?

1 Like

It shows “Enable” - is that it? That’s all it takes?

I went ahead and tried it - it worked! Thanks a ton!

The reason I deleted it is because it was still picking up some certificate from the previous host who was using “Let’s Encrypt”. I figured the option to reinstate it would be in the same section/panel.

Thanks again

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.