Access to my email after transferring to CloudFlare

Hey,
I looked for the answer and what I found I supposed to change my mx records or add something, but I’m not sure how, because I tried and it’s not working.

The problem is, that I can reach my email through webmail ( I can send and receive emails). But I cannot connect to my email on my iPhone. When I add details about my email and try to connect, it says that “The IMAP server “mydomain.com” is not responding.”. It worked well before and I didn’t change anything.

In my DNS records I have these records:
Type : A , name : mail, content : (some ip address) , proxied
Type : mx, name: mydomaincom, content: mydomaincom, priority: 10, DNS ONLY

Hi @kontakt20,

You need to set that IMAP server to a :grey: hostname, not an :orange: one.

I would set your mail record to :grey: and change the IMAP server to mail.domain.com.

Which exactly settings should I change in the my DNS records?
The result should be like this? :
Type : A , name : mail, content : (some ip address) , :grey:
Type : mx, name: mail, content: domain.com, priority: 10, :grey

Can you post a screenshot of your DNS page? It’s ok to black out IP addresses.

I think you’re trying to use the example.com hostname for a mail server, but it should be mail.example.com, so it would be set to :grey: while example.com would be set to :orange: for your website.

Here’s @domjh’s tutorial on email settings:
Troubleshooting Email Delivery Issues when using Cloudflare

1 Like