Access to cPanel on port 2087

Answer these questions to help the Community help you with Security questions.

What is the domain name? Kitworld[dot]uk

Have you searched for an answer? yes

Please share your search results url:

When you tested your domain, what were the results? it doesnt work

Describe the issue you are having: before moving my website behind CF, I could access cPanel on port 2087. Now I cant.

What error message or number are you receiving? Timing out.

What steps have you taken to resolve the issue?

  1. I looked at the WAF to see if it was blocked.
  2. Tried contacting support at CF which seems to be impossible.
  3. came here

Was the site working with SSL prior to adding it to Cloudflare? yes

What are the steps to reproduce the error:

  1. Try to connect to port 2087 on the domain

Have you tried from another browser and/or incognito mode? no

Please attach a screenshot of the error:

Does your IP address end in 16? If so, I am afraid your does not respond on that port, which is why Cloudflare can’t connect either.

Hi there.

The website is up (kitworld[dot]uk) - i’m looking at it right now.

But i cannot connect to the cPanel for it anymore (on port 2087) as this port is blocked by CF

That’s precisely what I addressed.

The port is allowlisted to my IP address for Port 2087. All of my sites that are not behind CF, I can reach just fine. So clearly, CF is blocking 2087.

What i want to know is “How do i UNBLOCK it?”

Cloudflare is not blocking anything, if your server does not respond, Cloudflare can’t connect either, as already addressed at Access to cPanel on port 2087 - #3 by sandro

You best pause Cloudflare and verify if your site loads fine on the given port and clarify this with your host.

Sandro.

I have 30 websites on my server. 7 are NOT behind CF. I can reach them on domain[dot]com:2087 just fine … but i CANNOT do this with the 23 sites that ARE behind CF.

Then why does it not respond, as evident by my first reply?

it will for you Sandro - because on my server Firewall ht eport 2087 is only accessible to allowlisted IP addresses - ie - me.

Do you work for Cloudflare?

If you block Cloudflare addresses, then we know why that won’t work. You need to make sure the addresses at IP Ranges are white listed.

3 Likes

And it’s working

image

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.