Access returned "Unable to find the requested identity provider" when testing OTP provider

Hello everyone,

I am setting the one-time PIN identity provider using the term dashboard. Unfortunately, when I try to test it using the “test” link in the dashboard, access returns an error: Unable to find the requested identity provider. Strangely, if I try to access the application, it actually works fine.

What I have done so far:

  • Setup an auth domain
  • Add a login method, which is the OTP provider
  • Add an application, and an access policy rule

I would like to know if I have made any mistakes? Or is it a bug on access?

Thank you for your help.

Hopefully this is just temporary issue. Can you try again?

Unfortunately, it is still not working today. I even tried to delete the OTP provider and add it back, but the issue still persist.

I don’t understand what you mean by “test” link. Do you mean the link ends with cloudflareaccess.com?

I mean the link that you could find under Access > Authentication > Login > Login Method. It ends with cloudflareaccess.com.

I guess you need to contact Cloudflare Support regarding this issue. Nothing much the community can assist about this.

Okay. Thank you for your help.

There’s nothing to test. We have a ticket to remove the link to reduce confusions. Sorry about that.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.