About the Rules category

Welcome to the #general:rules category. Post here for questions about Bulk Redirects, Page Rules, Transform Rules.

4 Likes

EDIT: I have resolved the problem – it was because I had not updated my DNS to point to the IP for archive.org

Hi,

I have a simple case that I’m struggling to implement.

I have had a problem with the host machine for my site and so need to temporarily redirect my URL to the URL of the Wayback Machine’s cache while I get it back up and running properly. It’s really important that my URL doesn’t just resolve to a dead page.

I have created a bulk redirect list with my source URL as mypage.com/ and the target URL as https://web.archive.org/web/datestamp/http://mypage.com/ (and the same thing again with the www subdomain).

I have saved and deployed the list and it is set to “enabled” but nothing is happening and I feel like I have missed something obvious…

Any ideas?

Thanks,
Ad

Response Transform Rule Preventing Font Rendering

First time poster - I’ve encountered a really weird behaviour that I think might be a bug.

If I have an HTTP response transform rule (for content-security-policy) enabled my self-hosted fonts are loading, but not rendering. Even innocuous transformations that shouldn’t impact fonts.

Scenario 1

  1. Single transform rule with the following config: Set static — Content-Security-Policy — frame-ancestors ‘none’;
  2. Purge Everything in the Cache Config page
  3. ctrl+f5 to reload my site’s home page on any browser
  4. In dev tools > Networks, check that the content-security-policy is included in the home page response (can take a minute or so - if not, rerun ctrl+f5 on previous step)
  5. Observe font
    RESULT: The custom fonts load and render correctly

Scenario 2

  1. Single transform rule with the following config: Set static — Content-Security-Policy — frame-ancestors ‘none’; default-src ‘self’; <<i.e. one extra value added on compared to previous
  2. As before, urge Everything in the Cache Config page
  3. As before ctrl+f5 to reload my site’s home page on any browser
  4. As before in dev tools > Networks, check that the content-security-policy is included in the home page response (can take a minute or so - if not, rerun ctrl+f5 on previous step)
  5. Observe font
    EXPECTED RESULT: The custom fonts load and render correctly
    ACTUAL RESULT: The fonts load (I can see they have successfully loaded in Sources) but they don’t render.


This screenshot is Edge. I can see the fonts have loaded successfully from Self. I can also see that a base64 image has been blocked by CSP - which is expected as I haven’t enabled data: for img-src. So the font isn’t being blocked from loading by the CSP (it’s black, not red), but something is stopping the custom font rendering.

My fonts are definitely self hosted!

I’m Facing this issue with my compare page

Thanks and Regards