A Records not Propegating

dns

#1

For https://melaniedavisphd.com/ we have the name servers pointing here to CloudFlare. I have A records set up to point to 50.62.172.157 however I am seeing 104.24.113.160, which is not even in my DNS records. The site is down. What is going on?


#2

When Cloudflare is on :orange: than it sits in-front of origin server (50.62.172.157) to cache, optimise, filter and proxy requests. It can only do this because the requests go to Cloudflare’s IP’s such as 104.24.113.160.

If you want to Cloudflare to only host the DNS than you can turn the CDN features off :grey:


#3

Thanks for the quick reply. Of course I want Cloudflare’s caching. Your explanation is great and although I appreciate it, it brings me no closer to the real question. Why is this site down? =(


#4

Oh I missed that part when I was reading your post.
Your website seems to only reply with redirects. If you have Flexible SSL enabled this might help:

Do you have any redirections on your origin server? I suggest you disable them for now.


#5

I am going to make that as the right answer! Full disclosure – I read the article but didn’t follow it. I am pointing my name servers back to the origin and decoupling from Cloudflare. Less to deal with.

Thanks again public[]!


#6

No worries, Did you have TLS (https) before you moved the DNS to Cloudflare? If yes maybe just set the SSL setting to “Full (strict)” under the crypto tab, before you disable Cloudflare.
:smile:


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.