@ a record website not found - DNS Only - reserved IP

I am having an issue with connecting to the @ record for my Shopify site https://godavaridiamonds.com - its comes up with a page not found error. I believe this is because the website was hosted in Cloudflare prior to March 2020 although the NS was with the registrar. This has been working fine but stopped working about 2 weeks ago.

I have since added the domain to my Cloudflare account and moved the NS to Cloudflare - but it still doesn’t work.

www works fine. Redirect is disabled at present.

Shopify can find no issues at their end.

When I try to proxy the URL I get a 1004 error. Once added without proxy I cannot select proxy - “DNS only - reserved IP” Same applies to the CNAME “DNS only”

@ → 23.227.38.65 which is Shopify’s public IP
www → shops.myshopify.com

Any thoughts?

Are you sure godavridiamonds.com is the correct domain name?

Are those records set to :grey: DNS Only?

Sorry - missed an “a” - edited URL above.

I dont have the option to change DNS Only:


The cloud symbol doesnt exist - even if I delete and re-add the record.

‘shops’ ends with a 74 (and this one works for you), but your apex domain ends in 65. You can try changing the 65 to a 74.

If that doesn’t work, then delete the “A” record and then follow this tutorial if you want ‘www’ to be the canonical (actual) URL for your site:

1 Like

I had tried that and the result is the same.

We want https://godavaridiamonds.com to be the actual URL for the domain (with www redirecting to it) and this has been working fine until about 2 weeks ago. No changes were made to either the website or DNS to cause this - it just started failing spontaneously.

I’m still of the opinion that there is some legacy entry left over from pre March 2020 that needs to be removed from Cloudlfare - no one seems to really understand how Shopify and Cloudflare interact with each other - hence the “DNS only - IP reserved”

You’ll have to take this up with Shopify, as you’ve done exactly as they’ve asked.

“No one”? Plenty of people do, and it’s not always smooth sailing. Shopify runs their storefronts through Cloudflare’s Enterprise Plan, but if anybody else ever did the same with a particular domain and it breaks Shopify, Shopify will look the other way as you scream for help.

1 Like

Which is what they are doing :frowning:

I have several pages of emails from Shopify - it took me about 10 emails before I even managed to get through to someone who even remotely knew how they interact with Cloudlfare.

This is the last reply from them:

My assumption here if everything is setup properly is the Nameserver. If we want to completely disconnect Cloudflare and use it directly they will need to be from the main registrar or a non Cloudflare Nameservers. In further details it does seems that it’s failing to sent the right directive in the http header which would coincide to a DNS record. It appears that there are some few articles as well on this matter on Cloudflare forum.
e.g
Site not working without www - #2 by andy
Subdomain not working when main domain is working just fine

Not a lot of help…

My opinion is that none of that matters. You’re using generic DNS Only entries. The name servers have nothing to do with this, as any name server you put your domain on will return the same information as a :grey: DNS Only entry.

1 Like

I agree :slight_smile:

But as Cloudflare proxies all Shopify traffic:

I still think Cloudflare is proxying to a webpage that no longer exists from the pre March 2020 website - that also no longer exists.

I’m starting to think the only way to move forward on this is to move away from Shopify / Cloudflare?

I mentioned that in my reply. If you don’t like how Shopify supports you as a customer, I suggest you look elsewhere.

I’ll update Shopify with that info.

1 Like

OK - so it ended up being an issue with a custom hostname in Cloudflare that Cloudflare had to resolve. But they would only do this under instruction from their original client - Cloudcannon - who had not been involved with this domain for over 18 months.

They would not deal with Shopify on this issue so Shopify had zero blame and full marks to them for being able to point me to the actual cause.

Still waiting for an explanation from Cloudflare as to why this was allowed to happen - expect I may be waiting a very long time…

So someone with no authority over your domain has this type of power? That’s ridiculous. Cloudcannon could have just ignored Cloudflare, and then where would you be?

In my mind, this is the main argument against cloud based services and why 99.99% of what we do is on prem. If something goes wrong on prem it is very clear who has to fix it.

Image if Cloudcannon didn’t exist any more…

1 Like

There should be absolutely a way to quickly demonstrate control over a domain to be able to proxy it. After all, the :orange: Proxy option is right there in the DNS settings where a TXT record can do this.