A record not working (I get a 404 error)

In the domain saavedrapropiedades.com I created an A record with the name saavedrapropiedades.com to the IP, and a CNAME www to saavedrapropiedades.com.

For some reason it isn’t working and instead I´m having a 404 error (which seems to be a Cloudflare page). If I ping the domain I get the IP, which it seems to be a Cloudflare IP ping .

Does anyone knows what I should change to make it work?

I am really not familiar with this kind of a 404 error page being served from Cloudflare:

This error is being served and shown directly from the origin host / server:

Have you contacted your web hosting provider if the domain is existing and what is the correct IP address to which you should point your DNS records to?

Have you got some content like index.html or .htaccess file in the “public_html” directory?

Is your web hosting account still active or was it maybe expired/cancelled recently?

May I ask does anything changes if you temporary switch your DNS records from :orange: cloud to :grey: (DNS-only)?

Furthermore, if I setup my hosts to propagate your domain name to your IP address, I got the following error:


Even if I continue, I got the same 404 page returned.

More about it here:

Before moving to Cloudflare, was your Website working over HTTPS connection?
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:


Hi Fritex,

Many thanks for your response!

  • I’m waiting from the host response.

  • In public_html there is a index.php and .htaccess files, amog others.

  • Yesterday I tried DNS-only but it didn´t work, so I clicked again on the cloud.

  • Before moving to Cloudflare, the website wasn´t working with HTTPS connection (the certificate had expired).


  • On Cloudflare I´m using the full SSL.

To make sure cPanel AutoSSL regenerate’s the SSL certificate, temporary switch from :orange: to :grey: and leave it for a day.

You could also trigger the AutoSSL to re-issue the SSL certificate directly from the cPanel interface by navigating to the “SSL/TLS Status” icon and clicking the button “Run AutoSSL”.

As @fritex mentioned, that should be Full Strict. Right now it is still insecure.

1 Like

Its working!
Thanks for the help!

1 Like

Did you switch to Full Strict?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.