A record change: propagation time?

90 minutes ago I updated the A record in Cloudflare to launch a new version of a website on a new server.

I started seeing the new website almost immediately, but I have no indication that anyone else is seeing it at all. When I connect through my router - both in my office and at home - I get the new site, and SSL shows it’s routing through Cloudflare. But when I connect via my mobile data I’m still sent to the old server.

I have clicked the Purge Cache button a couple of times. I also found the “Browser Cache” setting was at 4 hours…perhaps this is my issue? I dropped that, and also enabled Development Mode thinking that would bypass the cache, but these steps haven’t worked.

I used a hosts file on my local computer to log back in to the original site (WordPress) and made a change, but that change is not appearing. So something is going on, I just don’t know what.

Just wondering if I’m simply being impatient…which may be the case…or if there is something more I need to do. Thanks for any guidance anyone can offer.

Additional information: if I go to /wp-admin/ I am properly directed to the new server. So that, plus the fact that the index page is not reflecting my edit, leads me to think this may just be a cache issue. But at this point I’m getting concerned that I do need to take another step.

Hello @user42210 try clearing out your browser cache and data. That should help if you would like you can comment your website below and I can tell you what I see on my end.

Greetings,

Thank you for asking.

Usually few seconds or a minute/two.
May I ask you, can you share your website URL so we can double-check?

You can also check if the DNS records are proxied :orange: or not (:grey:).

Make sure to set it to “Respect Existing Headers”.

Furthermore, you can use “Purge Everything” button to clear all the caches at Cloudflare just in case.

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Otherwise, it’s due to your local ISP cache of DNS records. Might have to wait for 24 hours if recently switched domain nameservers at your domain registrar, so ti would fully propagate.

batesvilleinschools dot com

You should get one of three results:

  1. The new site, with a large video playing across the top.
  2. The old site, with a “coming soon” message that I put up shortly before the A record change.
  3. The old site, actually displaying the site itself after I went back in via the hosts file and turned the coming soon plugin off.

The fact that apparently everyone except for me gets #2 leads me to believe this is a cache issue. That coming soon message is no longer active on the old site but reflects the status of that site at the moment that I updated the A record in Cloudflare.

Thank you!

I have done everything you’ve suggested. My cellphone pulls up the “coming soon” when connected to mobile data. Any third party testing such as gtmetrix, etc. pulls up the coming soon also. But I went home - a mile away from the office, though on the same ISP - and I can get the new site as expected. So it’s not just

I do have my A records set to Proxied.:orange:

Should that be turned off? :grey:

I changed to “respect existing headers” about 2 hours ago, or 30 minutes after the initial A record change, when that was set to “4 hours” by default. We’re obviously still within 4 hours, if this might be a factor.

I see comming soon page and I see it’s proxied :orange: as it should be.

If you add /wp-admin/ on the back of that URL, do you get a WordPress login screen with a blue background? I’m finding that the proper login screen is coming up, even on the devices that otherwise are getting the Coming Soon screen when going to the main URL.

x-cache-nxaccel: BYPASS

Is this HTTP header coming from server or WordPress plugin?
I’d suggest you to ask your web hosting provider to clear the cache too, just in case.

Purge Cache (Everything) at Cloudflare.

Yes, correct. WP login page logo and blue background :+1:

Do you have a wordpress cache plugin, if so try clearing that. Afterwards clear the cache on the edge again. @user42210

I’ve done every purge cache operation I can find at Cloudflare, multiple times over the past 2.5 hours.

For hosting to clear cache…are you speaking of the old site, or the new site?

If the DNS records are pointing to your new IP, then the new hosting.

May I ask did you used Cloudflare since before from your old provider or not?

If yes, was it some kind of Cloudflare integrator partner / web hosting provider or you used Cloudflare individually?

Or this is your first time using Cloudflare, if so individually or you manage through some web hosting provider interface?

And you are using A type of DNS records, correct? Or rather CNAME setup?

I’ve never used Cloudflare except for this site. We put Cloudflare in place earlier this year, so the old site has been routed through Cloudflare for about 5 months. I set things up individually and accepted default settings everywhere. I didn’t touch anything again until a couple hours ago when I updated the IP address for the A records… I have A records set for both @ and www, not CNAME.

1 Like

I believe we now have it figured out. It was a problem with a website setting. I hate making mistakes but will admit when I have. This wasn’t a Cloudflare issue, nor was it a hosting issue. Just having additional sets of eyes on the problem, on both ends, was very much appreciated - and necessary.

Thank you for your time today in helping me with the situation. I truly appreciate it.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.