A Domain added to cloudflare and get NXDOMAIN errors

Hello,
I added a domain to cloudflare about 3 days ago.
I read some topics with this issue but couldnโ€™t figure it out.
my question is:
Is it normal to get NXDOMAIN errors after that period of time or should I get support for this.
Thanks,
Amir

May I ask what is your domain name?

Therefore, have you checked the tips from below article?:

How about DNSSEC?
Have you had it enabled on your domain before switching to Cloudflare?

  1. Verify you are using the correct IP address for your origin server for your DNS records.
  2. Flush your DNS cache and/or check your router to ensure itโ€™s not forcing clients to use itโ€™s DNS.
  3. DNS resolution is not happening properly, check to see if you have any typos in DNS details you shared with your registrar.
  4. Youโ€™re seeing errors like DNS_PROBE_FINISHED_NXDOMAIN or ERR_CONNECTION_REFUSED in certain geographic locations. Your ISP or local authorities are blocking access and there is little that Cloudflare can do. (If the local government blocks any particular website but a request reaches Cloudflare, we will not block them.) And note that DNSSEC does not help with government blocks.
1 Like

Thanks for the help, I have tried some of the advices and nothing helped.

Myy domain: fastweb2.co.il

thanks again,
amir

Do you still see errors?

I can open it normally and loads up fine.

Hello,
I solved the problem - when cloudflare copied the dns settings he missed few of them. adding them manually solved the problem.

Thank you so much for your help.

Amir

โ€ซื‘ืชืืจื™ืš ื™ื•ื ื‘ืณ, 5 ื‘ื™ื•ืœื™ 2021 ื‘-16:37 ืžืืช โ€ชsandro via Cloudflare Communityโ€ฌโ€ <โ€ช[email protected]โ€ฌโ€>:โ€ฌ

1 Like

I am happy itโ€™s working now :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.