A 522 error with Cloudflare Pages for subdomain site

Hi there,

I’m having an issue with the CNAME & DNS setup for a subdomain site (media.duncan.ie) running on Cloudflare pages. Any documentation I look up seems to point to the host not returning the site correctly. But in this case it is Cloudflare itself.

I already am using Cloudflare to run the SSL & CDN for duncan.ie. So the DNS settings are also coming from the Cloudflare panel.

I’ve followed the instructions for adding a custom domain to the Pages deployment, maybe there’s a step I missed?

Any help or suggestions is greatly appreciated.

media-2p0.pages.dev is working, but not media.duncan.ie (522)

P.S. these settings were applied yesterday, so I don’t think it’s a issue of waiting for the DNS records to update.

Greetings,

Thank you for asking.

I am sorry to hear that you are experiencing an issue with your domain and Cloudflare Pages.

I can reproducte the same 522 error when I visit media.duncan.ie.
For your domain name duncan.ie I see registrar status renewPeriod.

May I ask did you linked it in the Custom Domains section or you’ve done it manually?
It should be done through the Custom Domains setting.
If you done it there, what is the status of it?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Tagging @Walshy. Kindly and patiently wait for a reply.

In the meantime, regarding Cloudflare 522 error, may I suggest you to try looking into below articles to troubleshoot the issue:

2 Likes

Thanks @fritex,

Yeah it was done under the Custom Domains section. Pages > “Media” > Custom Domains. That appears to have an orange dot with “Inactive (Requires DNS setup)”. That’s in the middle part of the image I attached.

The SSL option under that tab is set to Flexible.

Thanks for the link, I went through the process again to be sure I was following the steps.

Looking at this link to check the CNAME setting externally, it seems that there is none. Even though the Cloudflare name servers are there.
https://www.nslookup.io/dns-records/duncan.ie

Thank you for feedback information.

Could you please switch your SSL option under the SSL/TLS tab to the Full (Strict) SSL instead? Therefore, wait for a few minutes and check if it works? :thinking:

2 Likes

Apologies @fritex , meant to get back to this sooner.

I can confirm that the SSL/TLS was set to Full (strict) last week, and that seems to be working fine for the root site at duncan.ie.

media-2p0.pages.dev is working, but not media.duncan.ie, still has the 522 error.

Might there be any other settings that might be interfering with this?


Hey,

I’m not seeing media.duncan.ie over here. I see media.duncan.com though, I believe you may have accidentally tried to link this to the wrong domain. I’d recommend removing your current custom domain and setting up a new one and making sure it’s media.duncan.ie

Let me know if you continue to have problems!

3 Likes

There’s a few strong words I’d like to have with myself on this :roll_eyes:

That’s working now. Thanks for spotting that @Walshy :tada:

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.