525 handshake failed

My website has been down for almost a week now: rewirewithsusan.com

The error on the page was “err_too_many_redirects

I’ve switched SSL from flexible to strict, purged cache and the error is now 525 handshake error

Nothing currently works. I’ve been on this for days, pls help with a solution asap.

Fixing your encryption mode was the first right step, now you need to make sure your server is properly configured as well.

I’d pause Cloudflare (Overview screen, bottom right) and make sure the site loads fine on HTTPS - you will probably have to talk to your host here - and once that works, you can unpause Cloudflare.

Cloudflare is the hosting provider.

Cloudflare is not a host unless you are using a dedicated hosting product, in which case you would not get a 525.

Again, pause your Cloudflare and talk to your host.

I will share the conversation I just had with my domain name provider here maybe that would help with context

By the way, I’ve paused Cloudflare

You did, now continue with the next steps

As long as your site is not loading on HTTPS, it cannot work on Cloudflare either.

Ok, so the site does not load on HTTPS. It returns the error: ERR_QUIC_PROTOCOL_ERROR. Who should I be speaking to about this? Who is the host here if not Cloudflare and namecheap?

As I mentioned, you need to talk to your host. Based on your IP address, it seems Namecheap is your host. The fact that they have no idea and send you to Cloudflare, does not speak of their competence and I’d consider changing host.

I’m seeing the www host returning a CNAME that points to app.buzzsprout.com. Visiting it loads the Rewire with Susan podcast feed page on their platform.

The Archive.org Wayback Machine shows that the apex domain went there as well as recently as May 10th. This suggests that Buzzsprout recognizes the apex domain as a valid hostname for your content.

Buzzsprout is your host because they are serving your content. When you switch from :grey: (DNS Only) to :orange: (Proxied), Cloudflare sits between your host and your visitors in order to provide various services related to performance and security.

There is currently no DNS record being returned for the apex domain. Until it has a record that points to an origin server, nothing beyond an error message is going to happen when anyone tries to visit.

If the destination you want for the apex domain is the same as the www host, you can use a non-routable IP like in a :orange: proxied A record for the apex domain in conjunction with a redirect rule that sends visitors to www.

The OP has been shifting around DNS settings. As mentioned before, Cloudflare should be paused for now and the OP should fix the certificate issue with the host.

Hi @epic.network. You’re absolutely right. Buzzsprout asked me to update the proxy status for CNAME records under the DNS settings and that fixed it
The site now works as it should
Thank you

Thanks @sandro, for your support as well

Your server is now configured properly, however it is still not responding on the naked domain. For that you could follow the redirect tutorial from #tutorial.

In any case, if you are on Full Strict you should be set and should be able to unpause Cloudflare.

Namecheap, if not your webhost, is where you manage your domain.
Because you point your nameservers to Cloudflare, Namecheap assumed your hosted on Cloudflare.

Your nameservers are pointed to Cloudflare. Cloudflare acts as a the proxy between your webhost and the web.

Looks like @epic.network was able to figure out who your actual webhost is.

Now go to ask for support from your webhost. :slight_smile: