525 handshake error

I have set up cloud flare on one of my sites for SSL. I have google domains and google cloud service for the site. Everything is fine except I get the handshake error. From what I can see the browser is not following the redirect. I have beatrixoshea.com redirecting to https://www.beatrixoshea.com perm redirect. 301. Use SSL. But the browser goes to https://beatrixoshea.com causing SSL error. When I insert the www it works fine. ??? Any ideas? Thanks.

That implies that the SSL certificate on your site is only valid for www. You have some choices:

  1. Use a Page Rule to redirect non-www over to www.
  2. Change your SSL mode from Full (Strict) to just plain Full (not strict) so it will accept a different hostname request.
  3. Update your server’s cert to include non-www.

Thanks mate. I’m a bit baffled as I have set up another domain in the exact same way and it works perfectly without this issue! But anyway mode is set to full not strict already. So that is option 2 eliminated. How do I go about option 3? Cloud flare SSL. Google domains and GCS for hosting. Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.