525 Errors happens regularly today on http call for resources


I just want to see if others people out there get also sometimes a 525 error (on http call for resources)

It does not happen consistently but I got it quite a couple of time on http call for resource (ie image, script) while making publishing modification on the website https://datacadamia.com

I tried to modify the SSL connection from Full (Strict) to another lowest level but I got an error 500 back while navigating.

For now, I have paused CloudFlare on the website, this is the only way that I have found to avoid this error.


Your whole server does not seem to respond.


A 525 typically indicates a broken SSL setup. I’d suggest to make sure the site loads fine again, then check that it loads on HTTPS as well and only then unpause Cloudflare.

That I’d leave unchanged and on “Full Strict”. This won’t fix a 525, the 525 is something you need to fix on the server.


You already posted that earlier. The issue is still the same.

Sorry. I have re-enable cloudflare. The site is no more down for sitemeer. I really don’t know why.
I’m going to try to understand why it’s going down.

Is your server configured to only accept connections from Cloudflare?

Right now your site is loading fine.

Yes, the server accepts only connection from the networks defined at:

I’m going to check the list.

That certainly explains why it did not work when unproxied.

Anyhow, right now it seems to work just fine. Double check your server configuration and make sure that your certificate is properly configured and you do not have e.g. a second configuration without a certificate.


I see now better what the Pause Cloudflare on Site is doing on DNS level.

The IPS cloudflare list that I gave to the server firewall is the good one.
(It was working on my side because I was on a accepted network as incoming connection).

I’m working regularly on this website to modify content, the last configuration has happen month ago and I got this behavior only today.

The same page after a reload would load the resources without problem. It’s much more a transitory problem that I got a couple of time.

In that case I’d go with that

Right now it seems to work fine.

If you get it intermittently that would mean your server drops the connections at times and/or returns an invalid SSL response, which is why I mentioned to double check that on your side.

On top of what I suggested earlier you should also check out Community Tip - Fixing Error 525: SSL handshake failed.

What you could try is to remove your firewall rules and allow all IP addresses to access your server. If you then do not experience the 525 any more you are most likely blocking certain Cloudflare datacenters.

I have added a monitoring check on our web server log.
I don’t see actually any http 525 status.
The error is may be gone.

Because this is SSL related, any problem on tcp connection should not create a 525, right ?
It’s just to know where I need to look to.

Thank you very much for your great expertise.

Thanks for the suggestion on Community Tip, the purpose of our firewall rules is to avoid bad agent and that’s why we are in first instance on cloudflare (to get a badbot, spambot wall)

I just see the point 6 for intermittent error at the community tips for 525

If you are the site owner and you’re only seeing errors intermittently, 
this suggests the TCP connection between Cloudflare 
and your origin is being reset during the SSL handshake causing the error. 
Ask your hosting provider/system administrator to check if there are any server issues. 
Reviewing your webserver access/error logs would be a good place to locate this information.

The errors did not appear immediately, I had to wait a couple of seconds/minute to get a 525 from the browser. A SSL Handsake fail would be immediate, no ?

You won’t get a 525 in your own logs as that is solely a Cloudflare error when they cannot establish an SSL connection to your server.

I’d still go with


A 525 can be TCP related, when something breaks the connection for example. I’d really try

1 Like

Thank your very much, you are really quick.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.