525 error under selenium webdriver test (ruby capybara)

https://termly-wix.tarokostaging.io I can access this site fine if I navigate to it from chrome browser.

Was the site working before you added it to Cloudflare?

yes, it was working fine, I didn’t even sign up to cloudflare prior to that.

when it first happened, I was able to launch another browser and access it okay. now I got the same error even from another computer.

A 525 error is typically caused by a configuration issue in the origin web server when its SSL certificate is not properly set up. Review the suggestions in this Community Tip for advice & insight.

1 Like

notice the message on the top left corner “chrome is controlled …”

It was working fine before until I tried to connect to it using automation. It is a hosted site and there was no change in configuration.

And now it’s not:

Have you followed the instructions in the 525 article I linked to?

it claimed the server is misconfigured. I don’t own the site myself, it is a hosted service. I don’t really understand why cloudflare got into the way and claim it is down.

Do you own tarokostaging.io, or is it just a service you’re using?

our company owns tarokostaging.io, which is on a hosted service called wix.

the thing I couldn’t figure out is how and why cloudflare got involved … I only signed up to cloudflare after seeing the error 525 message.

Because your company is using Cloudflare for its domain.

okay. now how come it was working fine until my automation script tried to connect to it?

this site currently only works with http protocol.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.