524 error / Timeout

Hi, could you help me with this error I keep receiving in the last 2 hours: error 524, a timeout occurred.

This is my domain: upbeatimpulse.com. What could be the problem here? I have transferred my nameservers to Cloudflare and added an SSL certificate and it has been functioning fine for more than 2 years.

5xx errors come from the web host, so you’ll need their help with this:

1 Like

Try to disable Cloudflare Proxy (orange cloud), and check if website works.

Is it needed to be done for all the proxied records? Thanks

Just for the main domain, without “www”. You need to make sure website works without proxy. HTTP version. You might also need to disable redirect to https version.

It’s still not working. What could I do next?

But you still have 301 redirect to https.

Also: Cf-Railgun: direct (starting new WAN connection)
If you have paid plan, you should ask support to help you.

No, I’m on free plan :frowning: I put " Always Use HTTPS" on OFF, is that it?

Yes, also disable “Always Online”. You need direct access you your website.


  1. Orange clouds.
  2. Always Use HTTPS
  3. Always Online
  4. Any other CF feature if any.

Make sure you don’t have https redirect on your website.

ping upbeatimpulse.com
You should see your server real ip.

Now it works but I don’t have the SSL certificate. Is the solution to purchase one to avoid this kind of errors in the future? And to return name servers to default hosting, or is it ok to stay?

SSL certificate is free. Your hosting provider should have it I guess.

I’m currently have same error 524, so I have to disable CF Proxy, so my website could work. I’ve installed personal SSL certificate on my webserver.
It looks like the same issue that I have.

It’s not free at my hosting provider but it’s not expensive, so I’ll purchase it. Thank you so much for your time. I’ll definitely try to avoid this kind of error in the future.

What kind of hosting are you using?


I haven’t used it, but


Is it paid?

Yes, it’s $8.88 per year, but the hosting is really affordable so it’s not a big deal

You might want to try this if you want:


$9 for free certificate is kinda greedy. :slight_smile:

Yes, I know, but I believe I’m not that skillful to use Let’sEncrypt. Thanks for the turorial, I’ll check it out :slight_smile:

CF proxy problem might be temporary. One day it should be solved I guess. :slight_smile:

But you should definitely try:


1 Like

BTW, do you have SSH access on your cPanel?