524 Error on My website

I tried looking at the CloudFlare guide on why a 524 error could occur. But I doesn’t make sense to me. My website was working just fine, hosted from SiteGround. I didn’t make any recent changes, and suddenly I was having this 524 timeout error. I can access this website just fine through a proxy, but not a vpn, mobile data or local internet. I’m not sure what the problem is. It’s this website: https://therevisionist.org/

Thank you, and I’d appreciate any advice! - Raqib

P.S.> Also let me know what pictures/info I need to show here so that you guys can help me troubleshoot the problem. Thanks again!

Hi @raqib.zaman,

There is a #CommunityTip covering the 524 Error:

I took a loot at that, I get that the TCP connection was made successfully. So are you saying it is a hosting problem? I asked the people from the SIteGround side, and they said that it was loading just fine. But when I try to access the website, I get the 524 error. But not through a proxy. But the same problem through VPN. Does that make any sense to you?

I turned off the proxy option from cloudflare, and problem seems to be gone now. What’s the reason for that?

No, I just said there’s a #CommunityTip about the error you referred to.

I tried to access your website, but it took a long time to load and ended up displaying the 524 Error screen.

As I don’t have experience with this platform - and therefore can’t help you better with this issue - I suggest you take a look at the other topics related to Siteground.

@raqib.zaman,
It is not recommended to share your origin IPs publicly. I advise you to remove this image.

But could you explain why removing the proxy fixed the 524 problem? Thanks!

Unfortunately, I can’t. :slightly_frowning_face: Let’s see if any other member can clarify that.

I think maybe it could have been because my W3 Total cache was misconfigured- I recently moved my website to a new host, and the caching was set to the old ip address & port…

Right now, I know the address to change, but not the port number. How do I know which port number to use for caching?

I’m sorry, but this is not a Cloudflare-related issue.

You should clarify this question through the plugin documentation, in WordPress related forums or even in more comprehensive ones such as StackOverflow.

I hope you succeed!

Makes sense to me. The host firewall is seeing a lot of traffic from a small set of connecting IPs. Looking like an attach, the firewall is blocking the traffic.
Your host needs to whitelist cloudflare’s connecting IPs.

Is that why turning off the proxies from the DNS config in cloudflare fixed the problem? Do I even need to use cloudFlare proxies?

Also, I find it surprising that a VPN had the same 524 connecting issue.

By the way, the people who work at SiteGround were able to access my website just fine, so that’ weird.

Well that’s up to you. If you want the benefits - yes.

They probably used internal DNS and hit the server direct, bypassing proxies etc.

Hi, I would like to interject. I was getting this error also.

To test a theory (because I wasn’t getting this error before going to https when checking with linkchecker).

My recent past history will show that I removed my site from cloudflare’s https and went back to http and turned off virtually all of the cf features (even setting the firewall to essentially off) for about 2 or more weeks.

Problem Solved: No more was I getting the Error: 524 Origin Time-out

What I noticed in going back to https using cloudflare is that the errors have returned.

Cloudflare is my domain name server by the way.

I read the docs of course available on cloudflare (that point us back to fixing our server’s setup files but I don’t think that might be it). I also of course tried going into DEVELOPMENT MODE and that also does not stop the 524 errors.

The errors do not appear to be item specific when I check my site with LinkChecker (i.e. one day it’s this file that is 524, then another day it’s a different file. If I let the linkchecker continue to the end of checking all then I simply get a bunch of 524’s reported but I usually just bail after they start coming in by choosing abort).

I think ultimately my problem was that my website was x.com but when i changed all the files in the site to be www.x.com it seems to have remedied the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.