522 error when using cf proxies

Hi I’m Merlin, I’ve been trying to figure out why my home server stopped receiving cloudflare requests.
This is a home network btw that’s why there’s a router at 192.168.0.1
I’m using traefik as webserver, pointing to nginx on melijn.me and www.melijn.me to serve a static file as test.

without proxy: http://melijn.me/ → 200
with proxy: http://www.melijn.me/ → 522

cf proxies work for my other domains, they worked for this domain and machine aswell until a couple weeks ago (I have no idea what caused it)
I read the articles on it on cloudflare’s docs and on here. I didn’t see something that fixed my issue.
My ISP (Telenet in belgium) says it’s not them and that they don’t block it.
I tried reinstalling ubuntu server 20.04 LTS already (its what the machine uses)

When I visit http://www.melijn.me I received (once, not reproducible, normal result is empty logs):

09:26:34.020889 IP 192.168.0.1.59295 > 192.168.0.33.80: Flags [F.], seq 758296707, ack 2651101644, win 1023, length 0
E..([email protected]?.(........!...P-2......P...,.....
09:26:34.254179 IP 192.168.0.1.59295 > 192.168.0.33.80: Flags [R], seq 758296708, win 0, length 0
E..(.,@[email protected]!...P-2......P...h...a.

But when I visit http://melijn.me I get a normal response ect.

>> sudo tcpdump -i enp6s0 -n -A -Q in dst port 80 and dst host 192.168.0.33
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enp6s0, link-type EN10MB (Ethernet), capture size 262144 bytes
09:28:06.579409 IP 192.168.0.1.50461 > 192.168.0.33.80: Flags [S], seq 2791559653, win 64240, options [mss 1420,nop,wscale 8,nop,nop,sackOK], length 0
[email protected]?.(........!...P.c..........................
09:28:06.581537 IP 192.168.0.1.50461 > 192.168.0.33.80: Flags [.], ack 945459594, win 1026, length 0
E..([email protected]?.(........!...P.c..8Z..P...".....
09:28:06.582466 IP 192.168.0.1.50461 > 192.168.0.33.80: Flags [P.], seq 0:98, ack 1, win 1026, length 98: HTTP: GET / HTTP/1.1
[email protected]?.(w.......!...P.c..8Z..P...?...GET / HTTP/1.1
Host: melijn.me
User-Agent: insomnia/2021.4.1
Accept: */*
Content-Length: 0


09:28:06.642041 IP 192.168.0.1.50461 > 192.168.0.33.80: Flags [.], ack 263, win 1025, length 0
E..([email protected]?.(........!...P.c.H8Z..P...!\...

My configuration is no SSL, no encryption because I get a lot of spam packets from plex on ssl.
How can I resolve this, why would I not receive these packets ;c
I’m connected directly to my isp’s router, port 80 and 443 are still forwarded as usual ect.
Could ipv6 have anything to do with this ?

Thanks in advance

Here are some attachments that might be useful



I solved it, my router was misrouting traffic, a modem/router powercycle fixed it <3