522 Error using nginx reverse proxy

I’m trying to use nginx’s reverse proxy but I can’t get it to work.

I’ve been using (and it has worked) a different method of reverse proxy by adding a subdomain per server but it has come to a point where it’s too much adding a subdomain every server I want to reverse proxy to, so I started implementing “domain . com/server1/” instead of “server1 . domain . com”

In this case I’m trying to add a Tautulli (web-based tool) into domain . com/tautulli/ but it’s not working.

Here’s my nginx config: https://gist.github.com/brvnogit/c029d107e511da81f6c5453734cee8a0

Until then, this was my previous (and working) config: https://gist.github.com/brvnogit/6d45b2a89780c6ae7335570ebb624ac3
Here I had an A record pointing tautulli . domain . com to my public IP.

I’ve come to the conclusion that it has to do with Cloudflare because if I remove it in between my connections, everything worked.

Irrelevant things because older config was working:

I have SSL/TLS encryption mode set as Full. The ssl_certificates in the config are the Origin Certificates given by Cloudflare.
Two A records poiting domain . com and www to the public IP where nginx is.

What am I missing ?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.