522 error on requests containing query string parameters through some data centres

Hey guys,

We’re experiencing an issue where some resource requests containing query string parameters are responding with a 522 error when Cloudflare is routing through an Osaka data centre.

The request we’re having the issue with is:


We have also experienced intermittent issues with the following, however the URL above seems to be consistently returning a Cloudlfare 522 error rather than it being an intermittent problem.


A few notable points about this:

  1. Removing the ‘?ver=2’ from this second URL allows the request to carry out successfully.
  2. This is only happening on some networks. The first URL responds successfully on my connection which is routing through Auckland, but not on my client’s connection which is being routed through Osaka. Note both my client and I are based in New Zealand so I’m not sure why the request is being routed through Osaka for her.

Interestingly if we disable Cloudflare OR keep Cloudflare enabled but remove the ‘www’ from the URL then it works successfully through the Osaka data centre.

Our hosting provider has advised they’ve whitelisted Cloudflare’s IPs so this is such a strange problem!

I’ve submitted a support ticket but don’t expect to receive a reply any time soon since we’re on the free plan, so if anyone has any ideas here it would be much appreciated! These requests are critical to the site’s functionality and without the CSS loading in the first request it is entirely broken.

Thanks a lot,


I am afraid, support will be most likely your best bet in this case.

Your issue seems to be highly specific and particular to one single PoP. That is not something that can be easily debugged by the community.

What I do notice, though, the query string in your first URL is quite long and about 1.4 KB large. However you do have the same issue with the second URL, dont you?

The fact that is only appears to occur on the “www” record but not on the naked domain is also noteworthy. Either there is an issue with that particular configuration on Cloudflare or the your webserver occasionally refuses the connection on the “www” record only.

Have you already tried purging the cache when the issue appears? Did this change anything? Any page rules or workers in place?

Overall however, thats something for support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.