522 Error on my website from some networks


After updating the DNS of my subdomain from IP address (Type A) to ELB url (Cname), am getting 522 error on my subdomain while connecting from the some devices. But its working on some set of devices. I tried clearing the cache, but still facing the issue. Can some one help me to debug the issue?

NB: Its working fine while am connecting directly to the ELB url

May I ask you what is your domain name and your sub-domain?

Can you check what have you got selected under SSL tab at Cloudflare dashboard? Is it Full SSL or something other?

Moreover, have you had an SSL certificate installed at your host/origin server for your sub-domain too or only your primary domain (if so)?

You are mentioning CNAME record, and “some devices” - maybe it is due to DNS cache at the ISP’s side too after you changed/updated your DNS records? (maybe it would need some time to wait to apply changes)

Could you check and does anything chage when you switch from the :orange: to :grey: cloud for your sub-domain DNS record at Cloudflare dashboard?

Regarding error 522:

Have you allowed Cloudflare IP addresses to connect to your new host/origin?
Maybe you need to allow Cloudflare IP addresses to connect to your host/origin server:

Due to if it has to be something about SSL, kindly check here:

@fritex Thanks for your suggestion.

I tried setting up the SSL again but the problem still exists.

Its working fine with DNS Only (:grey:), but not with Proxied(:orange:)
Also, it’s working fine when I tried with IP address of ELB (But I can’t use that since IP address may change anytime).

SSL mode is Full.
I have SSL for the subdomain also.

Sometimes the URL works on the mobile network, but not on wifi.