522 Error on Host

Hi, I am using Microsoft Azure for hosting my webapp. I am getting a 522 timeout error when I go to my domain. The webapp worked fine using the Microsoft provided azurewebsite.net domain. However, once it times out on my custom domain. I tried to troubleshoot and got this on Azure. Is the the reason for the 522 error? If so, how can I resolve this?


I think those two warnings are unrelated to the 522 unless Azure just wants to mess with you. Because you’re using Cloudflare, the cert and IP address aren’t going to match what Azure has for you on their host.

If you set DNS for vstudio.live to :grey:, does it work with HTTPS? (you’ll have to wait five minutes after setting it to :grey: for DNS to propagate.

No, I tried deploying the app multiple times over last 2 days and adding the custom domain again. It doesn’t work.
When I deploy on app service, it works with the azurewebsites.net domain they provide. The 522 timeout only occurs when I add a custom domain. Any idea when this maybe happening? Here’s my site: https://vstudio.live

You need to fix it in :grey: mode before you add it to Cloudflare.

what’s the :grey: mode?

oh got it, you mean I should set to DNS only.

1 Like

I set both of these record to DNS only 10 mins ago. Still doesn’t work. So, no problem with Cloudflare I am guessing? Also, do you know why my domain vstudio.live is pointing to two IP addresses. One of the IPs is pointing to azure but what is the other ip for?

I have no idea why you have two “A” records for that domain. Cloudflare probably scanned that when you added your domain, so something in your original DNS had those two records.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.