522 error in two US states

Recently, some of our customers in the USA get 522 errors when trying to access our website (based on Wordpress, running WP Rocket as a caching plugin). We know of a customer based in New Jersey and another customer from Florida who both can’t access the site anymore (it has started around 2-3 weeks ago for them).

These are the messages they received:

Error 522 . Ray ID: 667abb6ef8fb1821 2021-06-30 22:11:45 UTC
Connection timed out

Error 522 Ray ID: 66b2411fcab4099e 2021-07-07 15:54:57 UTC
Connection timed out

Error 522 Ray ID: 66b343a36aa401b2 2021-07-07 18:51:26 UTC
Connection timed out

Error 522 Ray ID: 66c0ae2f2dc6019d 2021-07-09 09:56:05 UTC
Connection timed out

We’ve already contacted our hosters and they confirmed that all Cloudflare IPs are whitelisted at their end. We also tried to access the website via countless VPN servers from the USA and none of them produced any errors for us. When we wrote to Cloudflare support, we only got an auto-reply by a bot asking us to go through the help section (which we had already done) or ask the community for assistance.

Is there any way to find out the Cloudflare server IP addresses based on the Ray IDs? We could then get back to the hosters and double check with them about the whitelisting once again.

Are there any other ideas how to fix this? It has always worked fine in the past or at least we haven’t had any complaints from customers in the last three years, so we’re a bit at a loss why this has started to happen recently and only for a very small number of customers (hopefully, since not everyone might get in touch with us).

That definitely sounds like your host is blocking the requests, you’ll have to contact your host again and ensure they have all Cloudflare IPs whitelisted - they are listed here IP Ranges | Cloudflare

Review the suggestions in this Community Tip for troubleshooting ideas.

Thanks a lot, I’ve just done this and will report back here.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.