522 error host - (host tells me i shouldn't use cloudflare.... )


#1

Hello everyone,

When i test my pagespeed using Google i get a 522 error host.
I contacted my host and they say: "people who use Cloudflare get those issues"

So i looked up some information and came across the following:

How To Fix CloudFlare Error 522

When you receive a 522 Error on a website, it is the server side error and CloudFlare is not to be blamed. It means CloudFlare is not able to establish a connection with the web servers. If the servers don’t respond to the queries within 60 seconds, the connection gets timed out and the website flaunts Error 522.

So they asked me to open a ticket and they would look further into it.

Anyone a idea what the reason for this issue is?


#2

Other than the Pagespeed problem, your site is working fine? How about trying Google’s Robots.txt tester to see if you also get an error:
https://support.google.com/webmasters/answer/6062598?hl=en

Also, do you use Google’s Webmaster Tools/Search console? Any problems there?
https://www.google.com/webmasters/tools/home?hl=en


#3

False. About 10% of the internet’s traffic goes through CloudFlare.

Typically this error comes up because of a firewall setting blocking CloudFlare. In some cases the firewall sees the same IP (cloudflare’s) too much, and further connections are blocked. The fix is to whitelist Cloudflare’s IP at the host/firewall.


#4

Okay, my host told me that they have whitelisted all Cloudflare’s IP addresses.
But it keeps showing 522.
I’ve checked the error in Google search console, the robot txt to the error 522 url is allowed.


#5

Did you mark those URLs as fixed in Google’s Console? If not, you should do so. Then wait a while (maybe a week?) to see if the error returns. For an immediate test - and indexing request - you can use their Crawl > Fetch as Google utility.


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.