522 Connection timeout in specific region

Hi Community,

Since 12:30PM my web server suddenly gives a 522 Connection Timeout, it worked flawless for almost a month and today it just stopped working. I can’t figure out why.

The origin server has UFW as firewall and i’ve checked everything double and its still correctly.

  • When connecting directly to IP or proxy disabled, it works
  • When pausing Cloudflare (right bottom corner link in Overview), it works
  • When using a VPN with location in a random country, it works
  • When using a VPN with location in the Netherlands, it works
  • Without VPN or anything else, it doesn’t work and returns 522
  • Our customers also get a 522 error, so its not my provider or connection or browser i guess.

What i’ve also tried:

  • UFW’s default policy uses a DROP, i’ve changed the default behaviour to REJECT so Cloudflare knows if UFW denies it (not working)
  • Checked with NMAP if the ports where open:
PORT      STATE  SERVICE
22/tcp    open   ssh
80/tcp    open   http
443/tcp   open   https
  • Checked if the server was directly accessible without Cloudflare proxy (works)
  • Reboot the server (not working)
  • Disable / Enable Cloudflare proxy (not working)
  • Checked if WAF was enabled (not enabled)

Am i missing something? Why did it suddently stop working?

The error that’s shown:

Thanks,

Sherin

Hello there,

Did you check #CommunityTip. I suggest you to check on it.

Read this article as well. Most likely there can be the problem with the ips.
https://support.cloudflare.com/hc/en-us/articles/115003011431-Troubleshooting-Cloudflare-5XX-errors#522error

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.