522: Connection Timed Out

The entire site works except for this javascript file required to edit pages in Wordpress …


Precise error …

Error 522 Ray ID: 4e9524845f5f733b • 2019-06-19 11:25:45 UTC

If the query string is changed to anything else it loads fine. Any ideas?!


Thanks in advance.

Server side error almost every single time…

A 522 error typically happens when Cloudflare requests to the origin (your webserver) get blocked. Review the suggestions in this Community Tip for troubleshooting ideas.

Thanks @matteo, already been there. We’ve passed this to the ISP support staff who are unable to replicate the error. I’m assuming that this is because they use their own nameservers and not Cloudflare’s.

Their most recent response was …

I have checked the error log on the server but I can’t find errors regarding this issue. Also, I can’t find a high load on the server when you received the error.

Any other ideas because I’m perplexed. Especially since the js file is returned by just changing one character of the query string!


Most often when they say that they are just dodging the question. Cloudflare never throws error 522 unless it’s coming from the origin.

I have a feeling this is going to turn into an infinite loop error :slight_smile:

Hopefully you’re right.

I have seen my fair share of people hat have encountered the error, with their hosts saying the same as yours. It has always been their fault…

And by the way the fine for me. With any query string.

Yes, I don’t doubt that this is ISP related … but it’s being able to prove it to them that makes it tricky.

Do you mean the file is being served for you even with the first link? It’s still showing 522 for me on both landline broadband and 3G. Also tried different browsers.

Yep, works just fine. Show the JavaScript file.

This is what the service provider say as well. I’ve tried again but still get the 522 error on both landline broadband and mobile 3G. Any idea why that might be?

Do you actually use Cloudflare when trying to access the website?

Can you trying doing nslookup pianolarestoration.co.uk on Windows or dig pianolarestoration.co.ukon Mac/Linux?

; <<>> DiG 9.10.6 <<>> pianolarestoration.co.uk

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27016

;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1


; EDNS: version: 0, flags:; udp: 4096


;pianolarestoration.co.uk. IN A


pianolarestoration.co.uk. 300 IN A

pianolarestoration.co.uk. 300 IN A

;; Query time: 144 msec


;; WHEN: Wed Jun 19 20:58:08 BST 2019

;; MSG SIZE rcvd: 85

Extremely strange…

Have you tried a different browser, I suppose?

So far I’ve tried Safari and Chrome on MaxOS, Edge on Windows 10 and Safari on an iPhone XS (not on the wifi). None produce the JS file, only the 522 error.

Just out of curiosity do:

curl -I https://pianolarestoration.co.uk/wp-includes/js/tinymce/wp-tinymce.js?ver=4940-20190515
HTTP/2 522

date: Wed, 19 Jun 2019 20:20:49 GMT

content-type: text/html; charset=UTF-8

set-cookie: __cfduid=d86ad382d47f67724fbec9d2e943f46841560975634; expires=Thu, 18-Jun-20 20:20:34 GMT; path=/; domain=.pianolarestoration.co.uk; HttpOnly; Secure

cf-cache-status: MISS

expect-ct: max-age=604800, report-uri="https://report-uri.Cloudflare.com/cdn-cgi/beacon/expect-ct"

set-cookie: cf_use_ob=0; path=/; expires=Wed, 19-Jun-19 20:21:19 GMT

expires: Thu, 01 Jan 1970 00:00:01 GMT

cache-control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0

pragma: no-cache

server: Cloudflare

cf-ray: 4e9834519ce2d8cd-AMS

It seems it’s local to some POPs.

Try opening a ticket with Cloudflare. To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. Please give Support the complete details and link to your Community post.

OK, brilliant! I’m not going mad! :smiley:

I’ll do that now!


It could still not be Cloudflare’s issue. Try mentioning it to the host, maybe they don’t see it because their POP doesn’t do the same thing.

This topic was automatically closed after 14 days. New replies are no longer allowed.