521 Error on my website (i changed the defaults ports)

Hello :slight_smile:
I’ve created a website (https://deliscord.cf),

And I’m using Apache for the webserver.
I changed the default ports (HTTP: 2052, HTTP: 2053).

But when I want to access the site, there is 521 error.
Can anyone help me ?

Thank you so much.

https://deliscord.cf:2053/ works for me. But you have not secured your Site with a SSL Cert. SO it complains about this.

Both Ports actually are supported by CloudFlare and you do not get any CloudFlare-Error so this have to be up to your Server Config. But therefore dont expect any help here. This forum is just related to CloudFlare, not general Serverhelp

Ok, thank :sweat_smile:

You are welcome. And if you use Raspberry you definitely should use a Port which is supported by CloudFlare so it can hide your IP (if you run it at home).

So you seems to be on the right way. Just secure the page and redirect from HTTP (2052) to HTTPS (2053)


But on the ip… SSL work perfectly

No actually it does not work properly, as you see the error-message.

If you use the IP you are bypassing CloudFlare completely as CloudFlare works on DNS/NS base.
On your domain a CloudFlare SSL Cert is put on. So I dont know why this is not working. But actually SSL should work no matter on which Port. At least as far as I know.

EDIT: got it: please do not use Origin SSL Certs from CloudFlare anywhere else then on domains which are getting proxied by CloudFlare (:orange:).
I bet deliscord.cf is set to (:grey:), right?

If you want to use CF Cert you can just set it to :orange:. Or go for a Lets Encrypt SSL Cert. But Origin Certs from CloudFlare are not for “unproxied” :grey: domains.

So there are 2 options:

  1. turn on proxy :orange: (I would recommend that due to the fact it hides your IP)
  2. use Let’s Encrypt SSL Cert.
1 Like

After set DNS to :orange:,
Now i have the “521 error”.

I do have a :orange: Subdomain pointed to a CNAME which is bounded to a DynDNS and which is pointing to my dynamic IP from my Router which is working fine.

When I call you page (:2053) I get Error 523 --> Please read here to solve this Community Tip - Fixing Error 523: Origin is unreachable

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.