521 error if proxy activated

i have vps,
I’m having problems with error 521.

the server is running normally, a problem arises when the cloudflare proxy is activated.

if the proxy is turned off the website can run correctly.

*note ip cloudflare has been my whitelist
*in 1 hour, the battery can get 20-30x 521 errors
*this problem only happened about 4-5 days ago until now

I also have this problem with my fps,

I get 521 if proxy Enable :face_with_symbols_over_mouth::face_with_symbols_over_mouth:

:wave: @aviprimananda,

Have you tried any of the troubleshooting steps in the community tips yet? That’s probably a good place to start…

— OG

1 Like

I tried

  • whitelist ip cloudflare,
  • install ssl on the origin server
  • Open ports 80 and 443
  • disable mod_security

Is your server listening on port 80 and 443? Is your SSL mode set accordingly?

1 Like

Yes
Full ( stric (

Fixed

Turn Off Raigun

Out of curiosity, did you see the railgun.wan_error connection failed error anywhere?

1 Like

I don’t know how to find the railgun error,

but after turning off the feature everything returns to normal,

I think the previous hosting party and my current VPS didn’t install Railgun

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.