520 Error – no error logs triggered

Hello, I keep getting a 520 error on my website. I contacted my host to ask them for web server error logs and they said:

‘We have gone through the web server logs triggered for your account and it looks like there are no errors being triggered on that date rather than just INFOs which are not fatal to the operation.’

The error goes away after refreshing, but it’s happening frequently.

Cloudflare Ray ID: 693e096eed856558 2021-09-24 18:22:12 UTC

Regarding Cloudflare 520 error, may I suggest you to try looking into below articles to troubleshoot the issue:

May I ask what is your domain name and who is your hosting provider, if so?

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Regarding available SSL options at Cloudflare dashboard, check here:

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.