520 cloudflare error

Hi Guys

I seem to be getting an error on my site the error code is 520

Could this be cause by a preflight request ? Since it returns a 204 ? Could cloudflare not be interpreting this correctly ?

Regarding Cloudflare 520 error, may I suggest you to try looking into below articles to troubleshoot the issue:

May I ask what is your domain name and who is your hosting provider, if so?
Maybe some recent and planned maintenance period at the DC from your hosting provider?

Before moving to Cloudflare, was your Website working over HTTPS connection?
If so, did you had an valid SSL certificate installed at your origin host / server which covers both your naked (root) domain any any other needed sub-domain like www, mail, etc.?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Regarding available SSL options at Cloudflare dashboard, check here:

If any other issues appear, follow the needed steps for troubleshooting from article below:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare CA Origin Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Ports list compatible and supported when using :orange: cloud (proxy mode) on Cloudflare can be found here:

Furthermore, kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

1 Like

The server has fulfilled the request but does not need to return an entity-body, and might want to return updated metainformation. The response MAY include new or updated metainformation in the form of entity-headers, which if present SHOULD be associated with the requested variant.

For that, use the link @fritex provided!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.