503 Service Unavailable - The origin has been unregistered from Argo Tunnel


#1

I have been using Argo tunnels for two weeks so far, and I have created a cloudflare account just for this specific feature. My interest was to use an argo tunnel to expose internal web applications externally, instead of using a VPN or a port forward.

My environment is relatively simple: ubuntu 16.04 with Jenkins running in a docker container, and reachable at http://127.0.0.1:8080. I am running the cloudflared program on the same machine, redirecting traffic to jenkins on port 8080 to make it externally accessible with something like https://jenkins.mydomain.com.

I used cloudflared login to authorize the tunnel and configure my cert.pem file, and it worked quite well. The problem is that the tunnel eventually fails in some way. I tweaked settings to disable all forms of caching, since I want to reduce possible interference caused by it until I have everything running stable. Restarting cloudflared usually “solved” the problem, but today I have a new problem: half the time, my tunnel loads a “503 Service Unavailable - The origin has been unregistered from Argo Tunnel” page instead of the good page. What is weird is that the other half of the time, I do get the right page loaded. I really looks like the page is somehow load balanced to an incorrect page.

I tried everything: purging the cache, deleting my cert.pem and doing cloudflared login again, increasing log verbosity, nothing works. When I get the incorrect page loaded, nothing shows up in the cloudflared log, so it doesn’t reach my origin. The cloudflared logs show that everything is up and running, and when the good page loads I do see it in the logs.

I subscribed to cloudflared just for the Argo tunnels, and I am really excited about the product in general. However, I find that there is still a lack in documentation and stability. Can anybody provide some guidance on how to resolve the issue and end up with a reliable tunnel that won’t fail once in a while? I have already wasted a lot of time on this, so I may end up having to go back to using port forwarding instead of argo tunnels if I can’t get this resolved soon.

Thanks!


#2

Hi mamoreau,

I reported this issue to CF around 4 hours before your post and was notified via ticket it was recently fixed.

You’ll need to restart your tunnel.


#3

@mamoreau, I’m the Engineering Director for Argo Tunnel. Please give it a try now. We recently pushed a fix that will take care of the 503’s, 525’s & 526’s some customers were seeing. Let me know how it goes, I’m happy to jump on a call with you and an Argo-Tunnel engineer if you think it will be helpful.


#4

Thanks! I searched for information about the problem, but I couldn’t find mentions of degraded services affecting argo tunnels on the status page. I restarted my tunnel this morning and now it is back to normal.


#5

Hi @joaquin, I restarted the tunnel this morning, and it has been working fine since then. Is this forum the right place to ask first if I encounter other issues in the future?

In any case, I am still very excited about the product, and I would have a couple of questions that might be best answered in an email conversation or a conference call.

Without going into too much details, I would be interested in bundling argo tunnel functionality within a product as a way to automatically expose a web application with valid HTTPS out of the box. PageKite offers something like that, but I would be more interested in a solution that uses the cloudflare infrastructure.


#6

The community is ok, the best place for support is through filing a ticket. I’ll reach out on a separate email for any other questions.


#7

Hi @joaquin,

We had to report the 502 error 2 days ago (acknowledged by support instantly) and then the 503 yesterday (back and forth with logs etc for several hours).

In both cases nothing was posted to the status page. It would be nice to have this updated as we’re now relying on Tunnel + Access for things people need to access to get their jobs done.

Thanks!


#8

Thanks @omar, we’ll make sure the status page is up to date. Feel free to reach out to me if you notice anything.