503 "no healthy upstream" in CF tunnels console

I installed a tunnel in my Ubuntu VPS using apt. Authorized the tunnel, everything worked. Then I just rebooted (to verify my services starts automatically), and now I cannot see my tunnels in the cloudflare administration console anymore.

This is what I see (status 503 for the first “tunnels” endpoint, status 404 for “subscription” endpoint):

What have I tried?

  1. switch off the cloudflared daemon in my VPS, wait, see if at least I get my tunnel is “offline” but I can manage it from the console. Result: nothing changed in the console.

  2. Saw the DNS config in the CF console, there was a CNAME that represented one of the two endpoints I configured in my tunnel previously, I deleted it.

  3. tested a “quick tunnel” from command line using

cloudflared --management-diagnostics tunnel --url http://localhost:5000

The quick tunnel worked, I could connect to the URL provided, but the CF admin console error was unchanged

  1. Tried recreating the certificates with cloudflared tunnel login. The process went well, new certs. But the CF console still had the same problem as in screenshot.

Extra info:

  • I installed cloudflared via apt, and all was good before the reboot
  • I have a routing CF worker that operates
    Ran out of ideas here. How can I change

Tunnel information is now located in the Zero Trust page and not in zones

I don’t think that was the issue, remember I got it actually working yesterday.

This morning the CF console responded well. I was able to see my tunnels. Must be some temporary malfunction.

I still had to delete and re-instantiate my tunnel though. And I had a lot of difficulty because this command does not clean up properly the previous tunnel:

cloudflared service uninstall

I had to:

 apt purge cloudflared
 dpkg -i cloudflared.deb
 cloudflared service install <new tunnel token> 

And now it works again.